McIntosh DAC and bitperfect playback

Hey all,

Decided to give myself a nice birthday present and splashed out on the lifetime roon access. So far I am impressed. Roon seems to be what my metadata hungry mind needed…

Of course as with every new software, I am still finding my way. Also found a lot of answers already in this community, but one thing I cannot get going is bit perfect streaming.

I am using a laptop as client, connect via USB to the built in DAC of my McIntosh MA7900. As soon as I engage Exclusive Mode, the sound starts skipping like a dirty record or even worse roon just skips all songs and does nothing. I think I have tried everything, but it seems like the McIntosh does not accept a bitperfect stream from roon. Before I was using foobar2000 on the same laptop without issues (although I cannot confirm bitperfect playback from foobar2000, since I do not know how to check this).

McIntosh has a pdf document in which they explain how to set up the connection with jriver for bitperfect playback. I tried to follow this, but am I correct that the roonspeaker control what I have seen here, will eventually be able do do the same?

Any thoughts, just be patient or am I doing something stupid?

Now I am using the normal non Exclusive Mode, sound is OK, but would like to be able to listen to bitperfect.

In case it is a limitation of the McIntosh, looking at the Auralic Aries line. Since it is out in the open that roon has contact with Auralic, will this be a bitperfect solution together with my McIntosh?

I had the same skipping and lower quality phenomenon occur after switching back and forth from Roon to Tune In Radio. I guess my remote got confused about who was in charge of the audio. Anyway, I powered DAC down, turned it back on, and the problem resolved itself- back to bit perfect again. Good luck!

I am using a rMBP with McIntosh D100 as well as C2500. There is no problem with bitperfect playback with Roon. I assume you are using windows?

Yes, I am using Windows. Also tried power cycling the amplifier and also the laptop. Even reinstalled the McIntosh driver. Still no luck.

Under private I see 2 McIntosh entries.

  • McIntosh ASIO [ASIO]. Using this output produces skips. All settings are disabled and DSD set to convert to PCM. Signal Chain indicator states “High Quality”
  • McIntosh USB Audio. Using this device in non Exclusive Mode works, but not bitperfect. Signal Chain indicator states “High Quality”. As soon as I touch the Exclusive Mode option, roon skips through all remaining songs of the album and thats it.

Under the McIntosh control panel I have the settings 32/192 and the Asio host can change box ticked.

I think all is set-up correctly, unless I am missing some detail.

Thanks for the help.

Hi @allineedis – sorry for the trouble here. I’m going to send you a PM and we’ll get some more information about what’s happening here. First we’re hearing of issues with this model, but I’m sure we can figure it out.

Stand by!

Hello, i am also having the same issue with my MHA100 as well. When i use the same USB port to plug in my Schitt Ygg, it stays the same ( high quality). Would love to find a fix for this.