Media Loading Slowly, playback keeps halting, skipping - Qobuz

Roon Core Machine

Dell Inc. PowerEdge R415
Dual AMD Opteron™ Processor 4122 @2.2 GHz, 8 cores total
Ubuntu 18.04.6 LTS installed
[Linux roonserve-2 4.15.0-166-generic #174-Ubuntu SMP Wed Dec 8 19:07:44 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux]

Networking Gear & Setup Details

Unifi USG-3P Router
Cisco SG-300-28 Gigabit switch
Google Mesh WiFi Model NLS-1304-25 Software Version: 13729.57.27

Connected Audio Devices

Pro-ject StreamBox Ultra S2 (WiFi)
Justboom (WiFi)
HiFiBerry (WiFi, via Squeezebox streaming built into Roon)
Several Chromecasts

Number of Tracks in Library

9746 tracks in library

Description of Issue

Qobuz media will stop playing and if I look at the Roon screen it will say “Media loading slowly” at the time. It will skip ahead to next tracks in queue, same thing will happen on those. Ultimately it will cease playback.

I have tried factory resetting the Pro-Ject stream box today and running it with default Roon settings, to no avail - same thing happening.

If you’d like to look at my Roon logs, the issue occurred most recently around 1500 EST / 16JAN22.

Please assist in troubleshooting this ongoing/longtime issue as it’s preventing proper use of some otherwise great software.

Hey @Zaid_Haddadin thanks so much for sharing all of this information with us - sorry to hear you’re having issues with playback.

How is your Core device connected to the internet? Is it connected to the switch or the router? As a test, could you please hardwire the Core to the router and see if that improves the issue for Qobuz?

Does this happen for all zones? Do you still experience this when you play to “System Output”?

The Core is connected to the internet via the Cisco SG-300-28 and the Unifi Router listed above.
If I were to hardwire the core to the router, then it would not be connected to any of my zones because the devices would no longer be on the network (the router is an enterprise grade security gateway with one LAN port set up which is designed to be plugged into a switch).

This seems to happen more when I have the Pro-ject Streambox S2, The hifiberry and the justboom all grouped for playback. I tried one other test which was to move the hifiberry to a raspberry pi3 and install HiFiBerry OS last night. It was stable last night with group playback. When I tried to resume the playback on the group this morning I encountered the dropouts and “media loading slowly” message.

I can’t really try to play to “System Output” of the core because it is an enterprise grade rack server in the basement with the utilities and doesn’t really have an associated DAC or output.

I’d be interested to know if we can learn anything that might point us in one direction or another from the server logs this morning when the dropout occurred.

Ok, new update @ashley - I made the following changes to the system:

replaced the Pro-Ject Streambox S2 Ultra with:
Auralic Aries D/A processor

moved the HIFiBerry DAC to an RPi 3 and installed HiFiBerry OS (allowing me to switch off the squeezebox support on my roon server)

The latest roon server update installed tonight (1.8 build 898).

I had no trouble playing DSD128 files to the Altair from Roon, however when I played from Roon/Qobuz the playback would stop in the middle of the first track and Roon would lose communication with the Altair.

In order to get the Altair and Roon connected again, I have to flip the power switch on the back of the Altair and let it completely power off and then flip it back on and wait for it to power back up and restart.

I am playing my second DSD album from the Roon server now with no trouble.
I think this troubleshooting demonstrates to me that the “pipes” (router, switch, WiFi AP) are fat enough to move DSD and the server can push it at the data rate required. So … I am dumbfounded by the Qobuz issues.

Could you please offer some assistance?

@Zaid_Haddadin my deepest apologies for taking such a long time to respond - I am so sorry! It appears that your message was lost along the way. I appreciate you providing me with an update so that we can continue to work on this together :pray:t3:

Usually, this error does point to a networking issue and the best way to determine if that is the case is to simplify the network and connections.

We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS. Can you please give this a try and let me know if it helps?

If changing the DNS does not help, could you please complete the following:

  • Stop Roon Server from running in the Web UI
  • Find and open your RoonServer database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon Server via the WebUI and verify if the issue still occurs

If the above steps do not help, we’re hoping that you can test out lowering the streaming quality. When playing from Qobuz, could you please go to Roon Settings → Services → Qobuz and lower the streaming quality. Do you notice any improvements?

Thanks so much!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.