Melco problem roon recognition

I received help from Peter to get my Roon software and Lumin streamer to run just fine. The chain of components ran as follows all Ethernet:

Desktop computer (Roon core)…main router…ethernet cable underneath house to audio room…then port #1 directly to streamer. Port #2 is Ethernet to dlink router as WiFi extender.

Everything worked great. The roon core on my desktop recognized the Lumin in settings/audio/Roon ready.

My Roon software on my iPad recognized the Lumin the same way.

But I also have a Melco N1A component. So after this fix I hooked up the Melco.

So instead of direct Ethernet from audio room jack to Lumin streamer, it now goes Ethernet Jack…Melco N1A…Lumin streamer.

With this configuration I have lost all recognition on Roon software. So I’m wondering if Roon won’t work with the Melco? If so I have a problem

Peter told me to power down the roon core, Windows, router, streamer, Melco. Then to power up everything. I did that. Roon software isn’t recognizing anything.

So I’m wondering if I’m faced with 2 possibilities with the way I’m currently hooked up:

  1. If I can’t access the Melco with roon, can I still somehow operate my Lumin streamer with this configuration with the Melco in the chain between the wall Jack and the Lumin?
  2. If not, then I have to always manually switch the Ethernet cables from the back of the Lumin and Melco depending on which one I’m listening to?

If it’s #2 then I’m worried. Because regularly switching the Ethernet cables between components is going to mess with the network configurations I would presume and be a pain in the butt

For other readers, this thread is a continuation of Roon not communicating with Lumin

The Melco Settings -> Network -> Player needs to be in Network mode. Direct mode won’t work.

After changing the Melco to Network Mode, power cycle the Lumin again.

1 Like

Okay. I brought up the Lumin app…as Melco says if the Melco is connected to a streamer then use that network player/streamer app.

I brought up the Lumin app and tapped the gear…i then tapped “select a Lumin” as it doesn’t say anything about a Melco and there is nothing there. The Lumin was there when you got it fixed for me yesterday

Melco setting, not Lumin setting.

When I bring up the Lumin app, I tap the gear which brings up the menu. At the top it has select and tapping that it is blank. It isn’t recognizing the Melco apparently. I don’t know why…as yesterday when you were instructing me at some point I saw the Melco but I don’t remember the circumstances.

I don’t see Melco anywhere.

Please read your Melco manual and configure it.

Okay I will look at this tomorrow. Thank you

Using the direct connection form Melco to streamer is only really designed to be used it your using the Melco as the source for streaming the music is its the UPnP server feeding the streamer. In your case your not it’s just acting as storage. All the data is going through unnecessary hops to get to the Lumin in this make up. As you have your Roon core pulling music from the Melco then pushing it back via the Melco to the Lumin.

In addition As Peter has said you can’t use the Melco in direct mode as in this mode the streamer is completely isolated from all network activity you use Melco to push music to it directly so Roon won’t see it and the lumin won’t see Roon. You can still have it attached if you feel the benefit of it’s worth it but the Melco needs to be in network mode or whatever they call it

Peter I did what you said. Now the Lumin app recognizes the Lumin. I have roon…settings…audio selected as Lumin on both desktop and iPad.

Roon on iPad or desktop not bringing up any music selections. Says “check your internet connection or your streaming services settings”.

:rofl: Classic.

“When all else fails, read the manual”
- anonymous

If you’re using Tidal instead of your music files stored in the Windows PC:

  • Logout from Tidal from Roon and from all other devices or smartphones including family members’
  • Reboot Windows
  • Login Tidal in Roon again

My goodness. It was a login problem on my laptop. Roon is playing my Lumin streamer with the Melco hooked up. Thank you

One last question Peter. And if this is not your perview/responsibility then that is fine I understand.

So I’m playing Tidal through my Roon with the Melco hooked up. Whenever I get music files into my Melco how can I switch to playing that? Is it done somehow with the Lumin app?

No, you don’t need Lumin app any more other than to do Lumin firmware upgrade.

I suppose you need to enable SMB file service from Melco, place some music files in Melco, then set Roon to scan the Melco via SMB.


Oh okay. The reason I asked is I see both the Lumin and the Melco as selections in the Lumin app. I thought it might be as easy as just selecting the Melco and go. But thank you I will look into this. James