Memory leak in Roon?! [Solved: Update to Build 970]

Hi everyone,

Our team has been tracking these reports, both here and in other places on community. I wanted to provide an update on where these issues stand.

We typically see performance issues like this happening on macOS or Linux setups. Windows and RoonOS work a bit different under the hood and so those platforms tend to perform much better in this area. The good news is there is work underway to improve some low-level architecture on macOS and Linux that we believe will be a big improvement. We don’t have any timelines we can provide at the moment, but work is already in process and we’ll be sure to update everyone when we can.

There are also specific bugs we’ve found — One specific to RoonOS which was fixed recently, and another related to network changes on Linux. A solution for the latter is currently in development as well.

We understand that this has been a frustrating issue for many, and we are hopeful that these changes will help alleviate many of the issues that have been reported.

In the meantime, if you’re using a larger library, our recommendation continues to be that you use a RoonOS or Windows Core for optimal results.

Thanks to everyone who has reached out to us about this!

15 Likes

Thank you Dylan,

You brought me back into the community with those lines. I like it when problems can be addressed and a qualified team works on them.

Certainly not every point of view or problem analysis will always be correct, but if there are substantive discussions and team activities, we are closer to a solution than if only silence and resignation dominate this community.

Keep it up

2 Likes

Hi Dylan,

Thanks for your information. I am really frustrated that my i9 64Gb mac is terrible slow and does not work properly.
I hope you will find the solution for MacOs very soon.
Thanks
Best Regards
Akos

Thanks for the update Dylan. And please keep us posted!

Just coming in from my other post with an update because that post has been closed. 3 days later, another gig of memory is being used. Now at 5.24G.

1 Like

I think we have two problems to solve:

  1. an ever-increasing memory requirement is building up.

  2. the system becomes unbearably slow with increasing use and database size.

  3. the integration of Qobuz

The first point concerns MacOS and Linux derivatives from the Debian family. With Arch derivatives (Manjaro) I could not verify this and my huge Windwos10 database (1.4 million titles) also constantly shows around 70 % memory utilisation with 16 GB physical main memory. But this does not protect me from the second problem.Manjaro and Windows also need to be restarted after prolonged use so that everything runs smoothly again.

With Qobuz, some have also observed that albums disappear and reappear days later. Qobuz itself is working on a solution. Unfortunately, I don’t have the possibility to use my Qobuz subscription via Roon yet, but Tidal plays perfectly and my collection also offers enough great playing possibilities :wink:

For point 1, Dylan has already lit a small light of hope here. Good luck and good ideas in developing this solution.

Solution for point 3:

I seem to have reached the limit given that now 4 days later memory usage has only increased by 300MB. I have however not really been using Roon, though I couldn’t really say I was using it much previously either. I will see if it spikes again after my next usage. Knowing that it only climbs when being used might be helpful.

@support, yesterday I update Roon Core to version 846 on my Synology DiskStation with DSM 6.2.4-25556 Update 2 (Linux).

From that moment on, the memory leakage issue seems to have been solved on my machine. Over the past few hours, Roon Core’s memory usage has remained about the same. The memory usage has even decreased somewhat compared to the previous Roon Core version. I will keep it monitoring and keep you informed.

Thanks for all your work.

5 Likes

Hey @Alfred_van_Hoorn

Thank you so much for this update, this is very welcome news! Please do let us know if you see any reoccurrence of your previous issues. If not, we’ll call this solved!

I’ll think, that it is to early to say, that the memory leak issue is solved.
It seems, that with 1.8 846 memory will allocated more dynamical and frees up sometimes, but we’ve to wait some days/weeks without restarting Roon to see, if there is a memory leak or not.

1 Like

Joy and hope may remain until this or another problem hits us. Technical experience inevitably leads to the realization that nothing may remain without maintenance.

Hey @Burkhardt_Petermann,

I stand corrected, what I mean to say was that hopefully we can call it sussed for @Alfred_van_Hoorn’s particular experience. Sorry to have made that unclear and provide the impression that we were stitching this up without appropriate due diligence. :+1:

1 Like

I’ll only know in a few days with any certainty if 846 has solved this on my Synology … but after 6 hours the signs are positive. :crossed_fingers:

4 Likes

Still looking good … Not seen this in a long time

Sure, we hope all, that the issue is solved :slightly_smiling_face:
But it can be different, in using a lot of endpoints, dsps or changing (import/export) files.
I’m also since many years software developer for bigger and critical systems and I know, that’s hard to fix really all memory leaks in complex systems.

I’m seeing really bad memory leaks here (1.8, build 831; M1 Mac mini w/ 8GB of ram; 61656 tracks, 9965 albums; no DSP; Qobuz, tidal & music on a local SSD) - over as little as 2 days it goes from 1GB of ram used to 12GB, at which point I get audio interruption during playback / the client seems to disconnect from the core for a a few seconds sometimes.

1 Like

I’m also having problems on an M1 Mac (16GB, running Monterey) and have a script running to reboot the core twice a week. Things seemed to improve when upgrading from Big Sur to Monterey, but the problem still exists: increased memory usage, followed by a slow down in peformance (loading album pages etc), followed by audio interruptions (ranging from momentary up to a few seconds or so).

This seems similar to the problem we had running Core on Linux, as long as it was based on Mono. With the recent new release based on .NET things have become much better. I remember a post where Danny wrote that he was pushing for having Mono replaced on MacOS rather sooner than later… this will be the solution to the degrading performance under increasing memory use.

4 Likes

I also see a memory issue and it cripples my entire Roon system after 48–72 hours. Only killing Roon Core and restarting that process (or a full reboot of the core) fixes this. It’s maddening and seemed to only become a problem since I upgraded to build 850. Linux Core here running on an Ubuntu Server running on NUC hardware.

Pertinent parts of uname -va
5.11.0-40-generic #44~20.04.2-Ubuntu SMP Tue Oct 26 18:07:44

Mines at 4.125G after 3 days. Just restarted and it grows quite quickly. Putting this here so that I can come back in 20 days or something and compare.