Meridian 218 Zone Controller Setup

Hi All,

I don’t appear to be able to setup the 218 as a Roon endpoint. Roon zone control indicates a broken link (when specifying IP address in setup)! Network scan + individual pings suggest that network connections (Ethernet) are good?

Roon is detecting the 218 as “HQplayer,” when I tried using “localhost” setup but, when trying to play anything I get error message “transport couldn’t connect to HQPlayer”!

I think I’m missing something here so any thoughts/suggestions would be welcome.



You are using the “Add Network Device” HQP section in Roon. You should remove the IP of the 218 from here as your are not using HQP in your setup.

With the 218 connected to the LAN and powered up, Roon should automatically find and identify the 218, it will then be displayed as an available device in the audio settings. Once that happens, select and enable it so it can be used as a Roon zone.

If your are running Sooloos back sure Sooloos is not streaming to the 218 at the same time doing so will force Roon to disable the device in it settings and it will no longer be available as a zone.

If that’s does not work, there it suggest a possible network issue… how are Roon and the 218 connected to the LAN? (Any WiFi or all hardwired).

As a test try switching off the firewall on the computer running the Roon Core.

Hi Carl,

I’m not sure what happened, but after removing the “HQ” zone and a restart of Roon the 218 appeared, I enabled it and…no sound output (digital in -> SL, might be a mapping issue here).*
Roon now shows media playing/progressing so I need to have a “dig” to check why there’s no sound. This is all very new to me so a step learning curve ahead :thinking:
Other main endpoint is suffering from dropouts (via 218) so a busy music free day or two ahead :slightly_frowning_face:

Thanks for your response.

P.S. No Sooloos here.

  • Honesty is the best policy -What a twerp I am, mapping changed “MUSIC” :roll_eyes:

Since Roon sees the 218 and plays to it, skip the SL for now and use an analog or SPDIF output from the 218, just to make sure the Roon part is all good. If it is, then you know it’s an all-Meridian issue – I know from experience those are a bit tricky to diagnose.

which connector on the back of the 218 are you plugging your speakers in to?

Sorry chaps, an aberration on my part! In my enthusiasm that I SOLVED the issue, by changing the mapping, my edit didn’t make my success that clear.

Apologies & thanks for your responses.


Speakers plugged into “Master Out.”

The dropout issue is “resolved” unexpectedly as the 218 switches & controls all of my equipment requirements (I now, potentially, have some redundant kit). Although, I didn’t figure out why a 192kHz signal into the 218 was suffering, the 218 should be able to downsample to 96kHz, in theory.

There a restaurant visit coming up!

Is the 218 fully RAAT like the Explorer2? My MS200 works well with Roon but cannot link to RAAT zones. Thanks.


I don’t believe Meridian has adopted the RAAT protocol, perhaps Mr Buchanan would have been able to provide an answer at the recent user group meeting had anyone asked?


Cheers Russ, I didn’t ask as that sort of thing wasn’t on the agenda for the day. Like you I wish they would adopt RAAT. The Explorer2 does this. Chris

RAAT is a networked protocol. The Explorer does not support RAAT – it is a USB device that can be connected to basically any RAAT supporting endpoint. All networking and transport is handled by the endpoint, which hands down the stream to USB.

That explains it then. Thanks.

Have the same issue - Roon not (anymore) detecting the Meridian 218. Things worked until yesterday and now the 218 does not show up anymore. I did try the “HQ Player route”, but that was clearly a mistake.
Meridian 218 Config sees the 218, my network utilities see the 218, it can be pinged, also from an iPad and it works fine(sends signal to my Meridian DSP speakers) through its other inputs (coax, Toslink), but Roon does not see it anymore.
Things I tried: removing and re-installing roon core, putting in place a new switch (Roon core and 218 are connected to the same switch), exchanging cables, rebooting everything including my router, assigning (and later unassigning) a fixed IP address to the 218. Nothing seems to bring back the 218 in Roon.
At this moment I am streaming music through an Apple TV unit, connected to the very same switch as the 218 and the Roon core, which is consistently being recognized and stable through all this, but that is a temporary solution at best.
At this moment I am considering whether my 218 could be defective (it worked for a week, then suddenly disappeared from view), but I would like to understand first whether there are things left to try.

Any suggestions (including @Eric) ?


Hi @Peter_Overbosch ---- Thank you for chiming in here and sharing your feedback. Sorry to hear of the troubles with the 218.

Moving forward, can you verify if you are able to successfully access web config for the device and if you can reliable ping the IP address being assigned to the unit.


Hi Eric,

Sorry to bother you again, but my road to Roon is not easy. As I mentioned in my original mail, the Meridian 218 web-Config program does connect to the 218, my network utilities (Advanced IP Scanner, Find MAC Address) connect OK to the 218, and the 218 can be pinged from my PC and also from an iPad.
Also, the 218 works fine (sends signal to my Meridian DSP speakers) through its other inputs (coax, Toslink).
The only problem is that Roon does not see it anymore. It streamed fine for a week and then suddenly was lost from Roon’s radar.

I intend to take the unit back to my dealer on Thursday to confirm the issue in their network. If the 218 is also not recognized there, it looks like a Meridian issue. If it is recognized there (but not in my network), it appears to be a local network/Roon issue and we must continue this discussion. I will let you know.


Hi Eric,

It looks like my problem is solved. My dealer showed me that the Meridian was OK, but my Roon core PC was not. I have now put Roon core on a different machine, which works fine. The original “problem PC” now gets a completely new Windows 10 install, and we’ll take it from there. For now I do have music and we may conclude that this was not about Meridian or Roon, it was about a Windows 10 installation on my PC. Anyway, thanks for getting back to me - and for the foreseeable future I hope we can stop meeting like this.


1 Like