Meridian MC200 - Audio drop out

Core Machine (Operating system/System info/Roon build number)

Macbook Pro running 10.15.4 / Roon Build 537

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Meridian MC200 connected to router via ethernet. MacBook Pro streaming to MC200 via wifi. Telus WI-FI MODEM T3200M. System and Macbook Pro no more than 15 feet from router.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

MC200 connected to Copland Amp via RCA.

Description Of Issue

Tracks will play part way through then audio will cut out. If I pause song and engage play audio comes back. It’s rare that you can get through a whole song without this occurring.

Roon continues to play while audio drop our occurs.

Also - my library is located on MC200. How can I access this library?

Hello @Gordon_Taylor,

Does this behavior only occur on the MC200 zone? If you try to start output to the Macbook’s System Output zone (the internal speakers), does that zone also have this issue?

You’ll need to add the MC200 as an SMB share in Roon. This thread from Meridian Unplugged discusses how to go about this:

Up until now I have not tried playing through desktop audio. Only through MC200.

I tried playing several tracks through desktop audio and they did play through without audio drop off.

Regarding access my music on MC200.

I’m not a tech person but I did manage to get it to work. Not quite like stated on link.

Enjoying audio should not be this complicated. I get that gearheads love this stuff but most people just want to turn their system on and enjoy music.

Once I got access to my music I tried playing from MC200 library.

These play without audio drop offs. I did get a couple of times when the music stopped but the actual track stopped. I think it was caused by the uploading.

Hi @Gordon_Taylor,

Glad to hear that you managed to get the MC200 working and that both desktop audio and on the MC200 itself.

What kind of content dropped off before? Was it TIDAL/Qobuz content only or did you have local tracks on the Macbook’s hard drive that were experiencing this issue?

The sound drop off occurred when playing from Tidal source. The Roon software shows that the track is still playing but no sound.

Playing from my library has another issue. The tracks simply stop playing part way through. When the sound cuts out I see that the track is stalled on Roon.

Now that I have access to the library on my MC200 I believe that Roon may not be the solution for me. Accessing the library is slow and each time a restart my MacBook Pro Roon has to reconnect to the library which can take a very long time.

Plus how do I use my iPad and iPhone to control my music.

I need a set it and forget it solution. An all in one box solution like the MC200 has been.

Hi @Gordon_Taylor,

When this issue occurs, what does the Processing Speed in Signal Path show? Does the issue only occur for higher-resolution tracks?

Since the dropouts are only impacting the MC200 zone, this could be an issue with the audio stream not reaching the MC200 in time, partly because your Core is on WiFi.I would advise trying an Ethernet connection in case this is the the limiting factor.

You can install the Roon app and then connect to your Macbook Core, please see:

Roon’s Architecture may be a bit different than what you are typically used to, but we find that Roon’s architecture provides a great implementation for high-resolution multi-room audio.

We can certainly troubleshoot these issues further if you wish though.

I tried connecting via ethernet. I was unable to see the MC200 as an endpoint. I found information online that it could be the router. I purchased a gig switch and this enabled my Mid 2012 MacBook Pro Retina to see the MC200 as an end point.

But I don’t want to use my laptop as the core.

I resurrected my 2008 MacBook Pro running 10.10.5. It cannot see the MC200 as an endpoint. I am able to connect to the MC200 music folder and access my music on the Mc200 but can’t play to it. I am unable to connect to Tidal. Could this be the OS?


Hi @Gordon_Taylor,

Glad to hear there’s been some improvement here with the gig switch!

It sounds like the 2008 Macbook has a firewall blocking Roon from operating properly. I would use these instructions to verify that Roon and RAATServer have been added to the MacOS firewall, and if you have any other antivirus or firewall software (Little Snitch/Bullguard/McAFee), I would try temporarily disabling them to see if this is the reason why you can’t locate it.

I was successful getting it working. Not an easy solution to implement. Fortunately I have some extra time compliments of Covid-19.

I was unable to get Tidal account active using the Core. I was able to activate account using the remote app on my iPad. Who new you could do that?

1 Like

Hi @Gordon_Taylor,

Glad to hear you managed to get the Macbook working in Core mode!
If you have any further issues, please do feel free to reach out once more and we can certainly assist.

How can I control my core with my laptop? I don’t always want to use the iPad?

Hi @Gordon_Taylor,

Please see: Running Roon as a Remote Guide (<- Clickable link)

That does not work. The Roon software loads and then tells me that my license only allows one core to operate and provides the option on “unauthorized”. No other option.

Hi @Gordon_Taylor,

It sounds like you clicked on “Use this PC as a Core” option. You’ll want to have the Core online and then it should pop up in the “Choose your Core” screen.

As a side note, I will mention that you can switch between Cores as often as you’d like, but you are limited to one active Core at a time is what the message is saying.

When you download the software (on Mac) and load it does not offer you the option “Use this PC as a Core”.

It loads and the only option offered is “Unauthorize”.

I am trying to use my MacBook Pro to Remote control the core running on my other MacBook Pro.

Hi Gordon,

2012 and 2008 MacBook Pro.

Which is the Core and which is the Remote? What Roon software is currently running on each? Was the new Remote Pro previously the Core?

Normally, when you have your Core up and running and then install Roon on another machine to run as a Remote, Roon will ask to accept the Terms and Conditions, then it will ask you to Choose your Core (at the bottom, it will say Set up Roon Core on the Mac).

It seems like you may have already had a Roon installed as a Core on the Pro that you’re trying to make the Remote. Is this the case?

Cheers, Greg

Hi Greg - yes the laptop (Macbook Pro running 10.15.4) I want to make a remote was originally setup as a Core. The Core is setup on an older MacBook Pro.

I tried deleting Core software and downloading new software. This did not solve the problem.


Did you remove the old Core in your library folder when you deleted the old software? Try the following to remove the Core and create a fresh install as a remote:

  • Exit out of Roon/RoonServer
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” or “RoonServer” depending on your install type
  • Rename the “Roon” folder to “Roon_old” or “RoonServer” to “RoonServer_old”
  • Reinstall the Roon App to generate a new Roon/RoonServer folder

Cheers, Greg

1 Like

That worked. Thank you.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.