Meriidian Ultra not recognised

Core Machine (Operating system/System info/Roon build number)
Panasonic PC.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Connect via wired connection.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Meridian Ultra via network.

Description Of Issue
Device does not appear in list of devices.

Ultra wired into router and green light flickering on Ultra.

Other devices do appear e,g, my Bluesound node 2i

I’ve jus logged into the router and the Ultra appears as a wired device ID41_0024c50011aa

IP address: so it’s connected OK

Hi, apologies if you’ve already tried this. If you go to Settings - Audio and check that your Ultra DAC is “Enabled” as it won’t show up in devices if it’s not.

Hi . When I go to Settings then Audio the Ultra or ID41 is not listed so I can’t enable it. Is that what you meant ? I do get a coupe of other devices listed; my Bluesound and my Google home and my Surround sound DSP

Yes that’s what I meant but you had obviously tried that. I used to have Meridian and streamed via the ID41 card but at times it could be a bit hit or miss and didn’t show up as available. You could try stopping then restarting the Roon App/Server. If that fails to solve it try the following:- The normal way to get round this is to switch everything off including router, any switches and the Meridian. Restart the router then any Ethernet switches followed by the rest of your gear. I sometimes found that I needed to power on then power off the Meridian even after doing this. It would then work after powering it on again. Hope this helps

Hi, I had already tried restarting the Roon server without success so I’ve gone for the total shutdown. No difference. One thing that does show up is a Meridian USB device as the PC once connected via USB to the Ultra, I obviously can’t enable it as an output coz there is nothing plugged into the PC The PC is now located elsewhere and anyway I want to connect via the ethernet not the USB

Hi John, that’s a pity. Is there any way you can hook things up temporarily with just your Ultra DAC and the PC/Server connected on a switch to your router without anything else connected? It’s a process of elimination at the moment. Worthwhile maybe trying another Ethernet cable just in case, unlikely but still possible.

I think @support will need to have more detailed information of your equipment and setup to diagnose the problem. Are all your other endpoints working okay?

Sorry I can’t be of more help but I’m sure someone will get to the bottom of it.

Hi John, just to confirm that you are powering the Ultra DAC down using the mains power supply and not just a soft power off/on using the buttons? I always used to hear a definite click from the ID41 when it was properly connected. Also worth checking that any firewall is set to off in case it’s blocking your connection from the U DAC. Sorry if these suggestions sound obvious but it’s worth checking.

Hi , Just tried that and no difference. I guess I’ll have to wait for someone from Roon to advise Thanks anyway.

Another couple of thoughts, are you able to login to the U DAC via the IP Interface on your browser to check the settings? If so is it set as a DHCP or Static IP, probably better to set as DHCP.

Can you also check that the “SLS” (ID41 Sooloos Input is selected) otherwise the ID41 may not work.

It’s a very long time since I done any of this so forgive me if I can’t remember all the setting details.

Let me know how you get on?

Just the same I’m afraid. I logged into the Ultra and it’s set to DHCP and I have been selecting SLS on the Ultra.

Cheers John. Can any of you guys help with this @Carl @ncpl @joel @support ?

I haven’t used an Ultra so not sure what setup itself is required. With other 8xx units you would need to load a config file that included the ID41 so the unit knew it was there to be used.

Do the Ultra need “typing” ?

Maybe I missed it but is this a new install or an existing install with a new problem ?

Check the firewall/virus software on the pc to make sure that no Roon exe’s are stuck.

Like you I have only used the 8XX series and not the Ultra DAC. It would appear that John had it connected via USB originally but has now moved the server to another room and connected via the ID41.

We have pretty much covered all the usual stuff but to no avail. I had previously mentioned to him to look at disabling the firewall just to see if it made any difference.

I’m not sure if the Ultra needs typing and don’t know if he’s used the Config Program to add the unit. I did ask him to check the configuration on his browser to see that things were set up correctly and he seemed to think that was all okay.

Thanks for chipping in.

Tried turning the firewall off; made no difference. I have used the config tools before but I haven’t changed anything about the SLS input so it should be the default setting but even if it wasn’t then surely the unit would still be recognised by the Roon Core ?? This is a new install of Roon. I am using a Bluesound Node 2i currently connected via optical to the Ultra but I spoke to Chis at Meridian and he thought I might get better sound quality using Roon via ethernet as there would be no conversion of the digital stream to optical in the Bluesound and it would all be handled by the ID41. Also I hear good things about Roon functionally.

Thanks for all your help so far. I hope I can get it working before my free trail runs out !

Hi John,
Thanks for the extra info. Usually when a Meridian zone isn’t seen it tends to be one of just a few things

  1. user error (mistakes we all make)
  2. a network issue usually like a specific type of router that is blocking multicast traffic (that devices like the ID41 needs)
  3. faulty ID41…rare but not impossible.

We should focus on 1 and 2

Your ID41 should appear in a section called “Roon tested”
You may have to scroll to see it listed down the page.

Double check.

Can you describe your network setup e.g. switches and routers in use between pc and Ultra


Hi Nick,

Under Roon Ready it lists my Bluesound Node 2i and under Roon Tested it list my Google Homes.
My Broadband router was supplied by TalkTalk it’s an OEM from Sagemcom FAST5364 3.00 . I haven’t found how to enable/disable Multicasting but I’m still looking through the menus .My Roon Core is a Panasonic Laptop Windows 7 hardwired to the router(I have tried wireless as well just in case) and the Ultra only has the option of hardwire which it is .

I’m a bit stuck

Any help appreciated


Hi John,
If you put this IP address into a web browser, do you see a page like this ?

If so this would suggest the ID41 is alive and kicking.

I would then suggest trying to rule out the router. To do that I would get or borrow a simple switch (not a router). Link the Ultra and laptop to that. If the ID41 appears then you know it’s the router.