Meriidian Ultra not recognised

Hi Nick, Yes I have already done that successfully. I have emailed Sagemcom asking about the router and multicasting so I will give them a chance to respond. I don’t have a switch but surely I could just connect the PC straight to the Ultra with an ethernet cable ?

Bye for now


Hi John,

I’m no expert on networks, but, to plug the laptop directly into the ID41 using a network cable I think you need to ensure they are set with fixed IP on the same subnet. You won’t be calling the DHCP addresses from the router. Others may be able to advise more specifically.

For the low cost and relative simplicity I would just try something like this (assuming it is a simple/dumb switch).

This will help rule out the router as a source of the problem.

I would agree with Nick, I’ve never known this approach. The normal way would be to go through an unmanaged switch and as Nick says its relatively cheap. I thought you had already tried this but you must have meant that you had made a direct connection?

No I haven’t tried connecting them directly (but it should work) so for the sake of a few quid I’ve ordered a switch.

Bye for now


Just thought I’d remove Roon s/w and re install whilst waiting for my switch to arrive. It made no difference !

Worth a try but as you can see other zones (that probably use a different protocol) it likely isn’t the issue.

Keep us posted anyway.

Hopefully you can get to the bottom of this soon John :crossed_fingers:

Hello @John_Forster, my apologies for the delay here. I have passed this thread over to our device team for a look, could you please reproduce the issue one more time and reply here with a timestamp when you do? I’d like to get diagnostics over to the team as well, thanks!

Hi Nuwiry,

Just checked again and nothing has changed. On the plus side I am still able to checkout Roon with Tidal in terms of functionality using my PC/Roon Core as the audio device ! My main reason for wanting to move to Roon though is to achieve sonic improvements as I won’t then be using my Bluesound to convert the digital stream to optical and then to the Ultra,but via ethernet from the core straight into the Ultra via the ID 41 card. Meridian advised me I may see an improvement ???

Many thanks

Hi John, just wondered how you’re getting on, did you manage to solve the problem?

No. Nothing from Roon yet and I’m still waiting on my switch to be delivered.

Hello @John_Forster, could you please check the Sooloos control app on a PC and see if you can see the meridian ultra from there? Please let us know!

Hi Nuwriy,

I am not familiar with Sooloos . Where can I download this control app from ? and I will give it a go. I had a quick google and only found a page on the Meridian website that was defunct !

Many thanks


Hi Nuwriy,

When I log in to the Ultra from the PC/Roon Core I get the following. Does anything seem incorrect?


ID41 status
Serial number: 100835
MAC address: 00-24-c5-00-11-aa
Sooloos Zone Name: 
ID41 #0024c50011aa Zone

Version numbers
Software version: 1.1, build 169
Co-processor version: n/a
Hardware version: 2.1

Current status
Source: Sat (standby)
Volume: 55

Comms configuration
System Address: 1A
Product Address: 8A
Product Category: 4C

Source configuration
 Sooloos	Other	Last Valid	Comms Type	Address
CD: 1C 1A
Radio: LV LV
SLS: 4C 8A
Disc: NC 1A
Tape: NC 1A
Cable: NC 1A
Sat: 3C 1A
Game: NC 1A

Startup source: SLS

Ethernet configuration
Active ethernet address:
Active ethernet mask:
Active ethernet gateway:
Active ethernet DNS:

DHCP:  Static IP: 
Static ethernet address: 192 . 168 . 1 . 123
Static ethernet mask: 255 . 255 . 255 . 0
Static ethernet gateway: 192 . 168 . 1 . 1
Static ethernet DNS: 192 . 168 . 1. 1

Not sure if it’s related and I may be mistaken but I think the software needs updating.

This should help.

Hi Matt,

I think we might be getting closer. I found v37 of the loader from the meridian website and when I ran it it didn’t find the Ultra on the network(despite it being visible when logged into the router). The release notes state that one is best to use a dumb switch since main routers can block multicasting. This has already been suggested as a potential problem & I have a switch on order. So we will see what happens when it arrives.

Many thanks


Great stuff, I remember going through the process of directly connecting a Meridian MS600 to a PC, as Nick described above, to resolve a similar problem some time ago. It hasn’t missed a beat since and I wish you the same when you’re up and running!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.