Mesh Network: Eero Pro?

That’s exactly what I did. Connected my Microrendu to the Eero’s ethernet port. Works like a charm.

had a very smooth experience installing this morning. basically shut down my fios router, unplugged my existing airport extreme, moved the ethernet cable over to the eero, and rebooted the router.

once up and running, i went into the eero settings and switched to bridge mode (the fios router distributes IP addresses), and all seems well.

coverage is better, network is faster.


I went eero too.

I did the opposite, connected eero to FIOS router and turned off the FIOS wireless signals. Eero is running the show. I had a couple of devices I had to reboot but most picked up without a hitch. I set the Eero SSID to be my old SSID and password so I did not have to update every device settings.

So far so good!

Amazon just bought these guys.

I bought their setup based on @AndersVinberg’s suggestion a few years ago. Had WiFi issues constantly for years and years until I set these up.

While their super turn-key-managed setup stuff was not my cup of tea for networking gear, I can’t argue with the zero effort these have been since installation.

I can see why they were acquired. They know product, and managed to do WiFi right.

1 Like

I’ve had no problems with mine at all. They just work. I’d’ve bought the company myself if I had Amazon-style money lying around.

1 Like

I use a Ubiquiti Unifi Mesh network with their managed gateway and managed switches. It’s by far the best wifi I’ve had at home. I started out with Google’s Mesh and it was more like Google’s Mess. It had very little insight into what was going on. At the time I had it, the logs weren’t available to the end user, just Google. The Unifi is quite the opposite. There’s as much finite control and reporting then most will ever need.
Ubiquiti has gone so far as to design AP’s that fit in a single gang outlet box that when installed look very similar to a blanking plate that you’d find on an unused outlet opening. It’s PoE and has a port that permits you to run a CAT cable to it. Basically creating a one hop home run to your Switch.

You can see one installed in the lower left of the leading photo on this page:

My eero system works great

Maybe Amazon buys Roon next, Eero and Roon go great together!

I predicted it here: :sunglasses:

1 Like

I am using eero and seeing “Too Many Failures: Stopping Playback” errors 98% of the time I try to use roon.

My eeros work perfectly for everything except Roon, so I tried eliminating them, and see that the issue is also present when I connect directly to the Fios without the eero.

So, I am just wondering if anyone else has had these issues?

Nope. I switched to an Eero pro network about a year ago when all my ancient airport devices started to crap out. it’s been flawless.

I’ve seen the error before, and it seemed more to do with an account error (Tidal/Qobuz) than with network issues.

Assuming you subscribe to them, have you tried logging out of your streaming accounts and logging back in?


Yep, that’s my experience of eero, too - it’s been wonderful for all my devices and every other app. I don’t think it’s to blame here, either, to be honest. Just trying to exhaust all possibilities.

I signed out and signed back in to no avail. I even changed my password as was suggested at one point and it still doesn’t work.

you might try cleaning up the library:

Clearing image cache:

And if all else fails delete the Tidal and Qobuz cache and re-start the core and re log in:
The below is where the cache is on ROCK so YMMV:

P.S. I had eero Pro with a slower internet (10 down/0.3 up) and it seemed that seemed to have periodic issues. I had even more issues with the slow speed when I was on the ISP provided router/AP. But ever since I got fiber (240 down/ 240 up, only eero for router and AP) I have not seen any of the same issues. So maybe internet speed and congestion might be contributing to your issue?

1 Like

I will try these - thank you!

Re: internet speed, last time I measured, earlier this week, it was over 900 up and down. I’m using Fios gigabit so I dont think internet speed is the issue, but I can’t be sure of anything so I’m looking at all potential issues.

1 Like

Have EERO Pro with Roon running from a diskstation to a number of players in the house. Never a problem. I wish I had got the EERO mesh years ago. It works so well with all the electronics in the house. Rock solid performance.

1 Like

I don’t use the Eero Pro, but have been using Eero 6+ for a more than a month now. My core is wired to the main unit and my main endpoint is wired to a satellite. I haven’t had a skipped Roon track since, either on my wired endpoint or other wireless endpoints.

This is the best upgrade to my audio system in a while :slight_smile:

1 Like

This is exactly what I had hoped my experience would be like! And it should be like this. If I didn’t think this sort of experience were possible, I’d just ditch Roon entirely. But, I want what you’ve got! :slight_smile:

There’s something I’m missing, but I don’t think it has anything to do with eero - it’s working as advertised for everything else. And again, when I took eero out of the system completely in favor of ethernet straight from Fios, the problem was identical to when it was connected via eero.

I’m having the same problem. I assumed it was the Eero. You’re saying you hard wired and the problem persisted? Did you find a solution?

did you remove the FiOS modem as well? it’s only necessary if you use FiOS TV. I don’t, so the the FiOS fiber goes directly to my Eero, which acts as the router. no modem necessary.

it’s rock solid.

Hi @David_Frantz – if you follow my thread here, nothing I tried had any effect on the issue, including hard-wiring and removing my eero network from the system entirely.

What ended up solving my problem was not exactly clear to me, but it IS solved, and I was right that it had nothing to do with eero.

After all the troubleshooting, one of the reps took a look at my account and saw that it had “flagged” for some reason, but I don’t know why and they never specified. Once that flag had been removed, Roon worked flawlessly in every configuration. It had nothing to do with eero or any of the other complicated bridging suggestions that were offered. Since the only program that I have an issue with on my network was Roon, it makes sense to me that the problem was Roon-specific, and not caused by an improper network setup.

“I had a chance to discuss your issues with our development group today. They’ve changed a flag on your account that will take effect after a couple of restarts. It may seem odd but doing it twice is necessary. Please let me know how things are going after doing this.”

I hope this is helpful. Wish I had more specifics to offer.

1 Like