Metadata edit not working

Yesterday I switched to Roon 1.1. Overall a very smooth experience and now finally AirPlay works on my Klimax DS. Can’t wait for your Songcast implementation so I can also play my Highres files in full quality.

Now to the issue I need help on. I have a few albums by a band called “5/8erl in Ehr’n”. All have the correct name in their ID tags. When Roon imported the albums one of them got tagged with the artist name “5” for no apparent reasons. Of course I immediately saw an opportunity to try out he new metadata editing feature in Roon. However, much to my surprise once I edited the artist name, the new artist name now had a blue 5 and the rest of the name (/8erl in Ehr’n) written in grey. The album is still not grouped with the other two and if I search “5/8” it does not show. Please have a look into this and let me know how to fix it.

screenshot please? the blue/grey seems wrong, but i need a bit more info which a screenshot should be able to provide.

as for the album’s “artist”, i have tried to sum this up here:

Screenshot as requested:

where are you taken if you click on the 5? to an artist named “5” or an artist named “5/8erl In Ehr’n” ?

A post was split to a new topic: Edit track numbers to text

Clicking “5” takes me to an artist called “5” with only the one album and no further links or information