Metadata frustration - Roon ignores my file data despite my specific request

I just ripped a ****load of CDs with dbPoweramp in which I specifically indicated the artwork and album titles and Roon ignores everything. So I go into “Edit” and specify that I would like Roon to ‘prefer’ the file data to their own options and … no changes. It still ignores my inputs. What gives?

I don’t think issue pertains to my set up apart from the fact that I use an iMac computer, rip my discs on an LG Multi Drive, software (as I’ve said) is dbPowerAmp - which allows me to modify all metadata PRIOR to ripping. I rip to a dedicated NAS (over 2500 CDs so far) and I would like to minimize having to correct things after I intentionally edit prior to ripping my discs.


I’m not sure about this, but I think you need to set Settings>Library>Import Settings before you add rips to Roon if you want Roon to use your own tags. To achieve (change) this after adding a rip, move the rip(s) out of the music folder, do a Library Clean up, select the settings you want in Settings>Library>Import Settings and finally move the rip(s) back into your music folder. Do a re-scan on the music folder.
Try it on a single album first to check whether it works as expected.

Thanks for the recommendation - all’s good now!!