Metadata improver error message question

@support
I have the same problem.
This seems to be a widely common and long standing issue.
Clearing the cache on the server by the user CAN NOT be the solution :roll_eyes:

Hi @Christoph,

If you reboot the Core machine is there any change?

Hi Dylan
Thanks for getting back to me?
I rebooted the Core Machine already several times, unfortunately to no avail…
Also when I add Qobuz Albums to my Library, it takes ages and when it is finally done, there is no Album Cover.

HI @Christoph,

Can you please share some more details regarding your setup?

What does the issue look like, can you share a screenshot?

Hi Noris
Thanks for getting back to me.
I added 2 Albums from Qobuz to my library and it took a very long time for them to be added and in addition what is even worse, there is no Artwork visible, only a grey placeholder.

Aslo the metadata improver is running nonstop

1 Like

Again some days pass by without ANY reaction :roll_eyes:
Are you trying to sit this one out?
There are a LOT of other people having this exact error message and this after several months knowing about this fault…

Hi @Christoph,

Hope you had a great New Year celebration and apologies for the delay in getting back to you here!
Can you please confirm what DNS server you are using on your router? Is it Cloudflare DNS, Quad9 or Google DNS? What is the model/manufacturer of your networking gear?

This happens frequently for me. Renaming the cache file works. Turn off roon, go into the roon directory and rename the cache file. When you turn roon back on it creates a new cache file. The system then will find the grey album covers and that ’ ‘metadata improver’ error message goes away. I have to do this once or twice a month.

1 Like

Hi @noris
Thanks for your reply.
My holidays have been very nice.
I hope the same for you.

Unfortunately I had the meta improver hiccup again.
My roon core is on a dedicated Win10 server with the music stored locally on 2 external 8TB USB disks. The roon core goes per Ethernet to a FRITZ!Repeater3000 and from there to a FRITZ!Box 7490 Router to the Internet.
Bandwidth and speed is NOT an issue.
I can use several endpoints streaming up to DSD128 to them simultaneously spread over 3 stories with another FRITZ!Repeater 1750E downstairs in mesh-config while whatching IPTV in HD without interruptions.
I don’t think I can change the DNS because that is given by the Internet Provider.

Everything is on the newest firmware/latest updates!

Thank you for your workaround but that is not a valid solution for me because my roon core is a headless server and to VNC onto the server, it has to be running and I don’t turn off roon without restarting the whole server machine.
This is also one reason why I feature requested the possibility to only restart the roon core like it is possible with ROCK!

I am also now getting this notification message…Please see my post, re Roon Internet Radio, posted today. (10/01/21)