Metadata Improver error message

Hi @Mikael_Ollars,

Thanks for running this test! So from what you’re saying is that this issue doesn’t occur on your hotspot but it does on the normal ISP network.

If you bypass the procurve switch as well, is there any change in behavior? How do you have the router and media box set up? Are they using default MTU values or did you set the MTU to something other than 1500?

No, thats not what i’m saying? This issue is independent of the network of choice. It happens on my regular LAN/WLAN as well as via a hot spot.

There are no particular setups being done to the router, all default. I just now noticed there was a newer firmware out, so i updated. I am convinced this is not the issue though.
Even if network stability was the cause for this, the metadata improver service for sure would need to perform more stable than it is at the moment. I mean, i stream TV and music on a daily basis as well as work from home over a VPN connection. None of these activities have any issues whatsoever, but Roon is a primadonna needing particular treatment?
I will directly attach my RoonUXCore wired to the router for a test later, but this is not a feasible solution in the long rung, theres no shelving around my router and it will need to be placed on the floor.
And to make things clear, this was not an issue before the previous version of Roon, and i haveNOT changed anything in this period.

Okey, i tried a couple of boots with my RoonUXCore hardwired to the Router, but i was unable to recreate the error at this time? I moved the Core back to its original position and performed a couple of reboots but even there, with the HP ProCurve in the equation everything worked just fine…

So, unable to recreate the error for the time being… :slight_smile: I even bought a few downloads and added to the library but they all identified just fine, and no messages about the metadata improver service fail.

1 Like

Hi @Mikael_Ollars,

Thanks for trying the Core directly connected to the router and for clarifying that this issue occurred via the hotspot as well. Do let me know if the issue returns, hopefully testing with the direct router connection resolved the issue, but let’s see.

2 posts were split to a new topic: Metadata Update Error: Windows 10 [Resolved]

3 posts were split to a new topic: Metadata Improver Error: SonicTransporter - Have to reboot

Hi Noris, just a quick update here. This issue occasionally still surface, and one reboot seem to always solve it for a longer period.
Something struck me regarding this though. I have, at the moment, a few Roon Cores running on my network and perhaps a pattern is showing? :slight_smile:
When i shift the Core to another hardware, i am asked to de-authorize the previous one, right? This works just fine, unless the Core has been offline for a looong time or was recently restored from backup which forces me do to a login, and that takes more than 2 minutes of annoying animated Roon logo, but still;
The de-authorized Core is still “licensed” as far as it’s concerned, for a few hours mostly. It seems that the Metadata improver error is ever present when i return to this core that has been deathorized after a day or so?

I am thinking along the lines of you not seeing the logs from a deauthorized core or so?

Hi @Mikael_Ollars,

Thanks for the additional info, but I’m not quite sure I understand here.

So you’re saying that the message only appears for you on the newly authorized Core that hasn’t been authorized in a few days? And this message appears pretty much as soon as you re-login?

Ah, no, nevermind that theory. :blush:
I thought it might have something to do with more than one core trying to get activation, but that doesn’t add up.

The only thing worth noting is that this occasionally resurface. But it’s completely random, and no changes have been made on my network or at my ISP. I can only conclude something is strange on the server side.

1 Like

Hi @Mikael_Ollars,

Thanks for letting me know. This issue is still one that we’re looking into, so if you do notice any patterns in the behavior please do let me know. We will of course also keep investigating this issue from our end with the reports we’ve gathered so far.

Has something changed regarding this in the latest release or server side?
A couple of weeks (or one at least) has passed since the metadata improver error reared its ugly head now.
And i have made some additions and adjustments to the library.

1 Like

Hi @Mikael_Ollars,

There hasn’t been any changes yet for this issue as far as I’m aware. We do have a ticket with the devs regarding this issue, and they’re still looking into it from what I know. In any case, glad to hear that you are not seeing this issue on your end any longer!

I’m still seeing it. Happening right now for the past week. I just haven’t made it to the core to restart Roon.

Sadly, i spoke too soon… Shouldn’t have typed anything… :wink:
I am coming back to my speculation that this happens when a core is de-authorized and files are added…
I have made an adjustment to my library which meant moving and adding some files. I have three Cores running constantly at this time.
Server on QNAP (QPG install)
Server on Win10 i3 8100
Server on Win10 i7 8700
(No full Roon on any of these, Control on iPads)
Basically, every time i switch to another one of these the metadata improver error has manifested itself…


I also run 2 cores on one license (not simultaneously). I will see if this problem seems to correlate to switching cores. Good sleuthing!


Thanks for the update here @Mikael_Ollars, sorry to hear it has returned. The devs have a ticket regarding the Metadata Improver error and they’re looking into it.

I can’t comment on when exactly this investigation will be finished, but we are aware of these reports and still investigating from our end as well.

Hi Noris, just reporting in that this keeps coming back in certain situations.
And, i belive i have seen the pattern which recreates this!
As i’ve told you previously, i run more than one Core at home and also have a portable setup for use in the “country house” or the RV.
The portable setup is a MacBook Pro 2017 with an external LaCie 5Tb harddrive. As i shift between different Cores i see the authorization screen quite often.

Since the MacBook is shut down after each listening session the behaviour is more easily spotted here. (at home the Cores are mostly running, whether active or not)

So here’s the deal;
If i start my MacBook Roon i need internet access, for my audio devices to be identified and for authorization. If another one of my Cores are holding my license at this time, i am presented with the De-Authorize screen and in this scenario i can promise you that my MacBook starts up displaying the Metadata improver message!
Since i usually reboot to get rid of the error message i can also assure you that it won’t come back after the reboot! (And not after any subsequent reboots or restarts, unless i have Activated another Core in the mean time)

So, my assumption here is that this error is related to whether the Core starting is authorized or not. And this makes sense, i don’t see it at home either when the particular Core is authorized, no matter if it’s rebooted or shutdown. It’s just when i shift Core’s and either; time has passed for it to request auth or if it’s being started up and not being associated with my license.

1 Like

I think this may be right. I’ve had the message switching between 2 crews for months. We’ve been in the middle of a move and only been using one core for a month and I haven’t seen that message. Something like the core tries to start pulling metadata from Roon’s servers before it is authorized, gets rejected, never recovers.

Yup, something like that!
And, i just had an arrend to my home, where my standard Roon Core was running on my NAS.

While at home i wanted to play some music, and as expected upon starting a Roon controller (iPad 2018) i was asked to deauthorize my MacBook Pro. When the QNAP Core was authorized it showed my Overview screen, where it was obvious that this core had developed the Metadata improver error. The authorization had been transferred to my MacBook Pro a couple of days ago. (I didn’t bother with restarting the NAS Core at this time)

Just got back to my cabin, and the MacBook Pro. Connected it to my Internet sharing on the phone and started the Roon Core, where it asks me to deauthorize my NAS Core. Sure as taxes the metadata improver error rears its ugly head when the MacBook Pro Core was ready!
I restarted the MacBook Pro Roon instance and; No more “Metadata improver error”…

Case closed, please fix this! :smiley: Seriously though, this is very annoying an un-Roonlike…

1 Like

Hi @Mikael_Ollars,

Thanks for the additional info here!
I have noted this with QA for their investigation, let’s see if it helps.