Metadata Improver error message

Hi @Mikael_Ollars,

There hasn’t been any changes yet for this issue as far as I’m aware. We do have a ticket with the devs regarding this issue, and they’re still looking into it from what I know. In any case, glad to hear that you are not seeing this issue on your end any longer!

I’m still seeing it. Happening right now for the past week. I just haven’t made it to the core to restart Roon.

Sadly, i spoke too soon… Shouldn’t have typed anything… :wink:
I am coming back to my speculation that this happens when a core is de-authorized and files are added…
I have made an adjustment to my library which meant moving and adding some files. I have three Cores running constantly at this time.
Server on QNAP (QPG install)
Server on Win10 i3 8100
Server on Win10 i7 8700
(No full Roon on any of these, Control on iPads)
Basically, every time i switch to another one of these the metadata improver error has manifested itself…


I also run 2 cores on one license (not simultaneously). I will see if this problem seems to correlate to switching cores. Good sleuthing!


Thanks for the update here @Mikael_Ollars, sorry to hear it has returned. The devs have a ticket regarding the Metadata Improver error and they’re looking into it.

I can’t comment on when exactly this investigation will be finished, but we are aware of these reports and still investigating from our end as well.

Hi Noris, just reporting in that this keeps coming back in certain situations.
And, i belive i have seen the pattern which recreates this!
As i’ve told you previously, i run more than one Core at home and also have a portable setup for use in the “country house” or the RV.
The portable setup is a MacBook Pro 2017 with an external LaCie 5Tb harddrive. As i shift between different Cores i see the authorization screen quite often.

Since the MacBook is shut down after each listening session the behaviour is more easily spotted here. (at home the Cores are mostly running, whether active or not)

So here’s the deal;
If i start my MacBook Roon i need internet access, for my audio devices to be identified and for authorization. If another one of my Cores are holding my license at this time, i am presented with the De-Authorize screen and in this scenario i can promise you that my MacBook starts up displaying the Metadata improver message!
Since i usually reboot to get rid of the error message i can also assure you that it won’t come back after the reboot! (And not after any subsequent reboots or restarts, unless i have Activated another Core in the mean time)

So, my assumption here is that this error is related to whether the Core starting is authorized or not. And this makes sense, i don’t see it at home either when the particular Core is authorized, no matter if it’s rebooted or shutdown. It’s just when i shift Core’s and either; time has passed for it to request auth or if it’s being started up and not being associated with my license.

1 Like

I think this may be right. I’ve had the message switching between 2 crews for months. We’ve been in the middle of a move and only been using one core for a month and I haven’t seen that message. Something like the core tries to start pulling metadata from Roon’s servers before it is authorized, gets rejected, never recovers.

Yup, something like that!
And, i just had an arrend to my home, where my standard Roon Core was running on my NAS.

While at home i wanted to play some music, and as expected upon starting a Roon controller (iPad 2018) i was asked to deauthorize my MacBook Pro. When the QNAP Core was authorized it showed my Overview screen, where it was obvious that this core had developed the Metadata improver error. The authorization had been transferred to my MacBook Pro a couple of days ago. (I didn’t bother with restarting the NAS Core at this time)

Just got back to my cabin, and the MacBook Pro. Connected it to my Internet sharing on the phone and started the Roon Core, where it asks me to deauthorize my NAS Core. Sure as taxes the metadata improver error rears its ugly head when the MacBook Pro Core was ready!
I restarted the MacBook Pro Roon instance and; No more “Metadata improver error”…

Case closed, please fix this! :smiley: Seriously though, this is very annoying an un-Roonlike…

1 Like

Hi @Mikael_Ollars,

Thanks for the additional info here!
I have noted this with QA for their investigation, let’s see if it helps.

Thank you! I have since my last post tried to puncture this theory but it seems watertight.

There is one thing i cant see though, and that is when and why a running Core develops this fault (because it will, when it becomes unauthorized).

Keep us posted!

1 Like

Can we please have this fixed? It’s pretty annoying to be forced into a reboot every time you switch to a different Core… And having more than one Core is a part of the Roon products spec and agreement when I made my purchase. To me, this has a much higher priority than the past few debacles called “upgrades”

This is why I dare not authorize my Dell laptop core. Last time I did, and then went back to Nucleus, I could not get rid of the problem and had to reinstall Roon.

Just as an update, this is still happening. It does correlate very well to un-authorizing a core and then re-authorizing it. Since a simple restart generally fixes it, I have to assume that the fix should also be quite simple.

The real irritation, for me anyway, isn’t actually that the core has to be restarted, although that is annoying. It’s that it takes Roon like 5 minutes to initialize and be ready for music playback after one starts it. So I’m ready for music…and Roon isn’t. That is why one has to leave Roon running and leave the core powered up.

After doing a diagnostic core swap, I also have the Metadata improver halted error occurring. FYI

Good morning,
Out of the blue, I have started receiving the above Metadata error message. I am running Roon on an iMac with Catalina; both Catalina and Roon are fully updated. Any helpful hints would be appreciated as this is very annoying (and uncharacteristic for Roon).
Frank Angelini

A post was merged into an existing topic: Adding Music To Library Wheel Keeps Spinning

A post was split to a new topic: Metadata Improver on SonicTransporter

This topic was automatically closed after 4 days. New replies are no longer allowed.