Metadata Improver Errror: Innuous

Same symptoms since last roon update.
I have applied suggested solutions but no improvement, iget a red warning but no software can be updated.
I run Roon in an Innuos Zen Mini mk3

Hi @ryoanji68,

I have split your post into it’s own thread so that I can better assist you. Is there any change in behavior if you reboot your Core and networking gear?

Can you please try logging out and back into any streaming services you have via the Roon Settings -> Services tab?

Hello Noris.

I ise an Innuos Zen Mini, the whole file library is in Zen’s hd and i have a Tidal subscription.
There is an usb connection in the Zen to a Chord Qutest DAC.

No change after reboot (done several times). It shows perpetual scanning activity and the message related to Metadata service stopped and Roon updated showed in the original thread of the forum.

I applied your suggestion:

  • Logoff Tidal service
  • Reboot

Now i see no scanning activity but a red alert icon in the top-right area. A click on it shows the same message as before: metadata services stopped an Roon needs to be updated.

If i start Tidal service, the red alert icon disappears and shows again scanning activity. A click on activity icon shows the same messages about metadata services and Roon update.

Zen provides logs of Roon activity (heavy zipped file, 98Mb). I could upload them somewhere if you need.

Thank you,

Hi @ryoanji68,

Yes, I would like a copy of these diagnostics. First, can I please ask that you log out of TIDAL, log back in and note the exact local time + date you performed this action here?

Once you have noted the timestamp, it will be easier to cross-reference the logs for this particular behavior.

I will send you a private message on where you can upload the logs, thanks.

Hi @ryoanji68,

Thanks for sending the log files over, I can confirm we received them properly. I will ask QA to review the log file, but to have all the necessary information available, can you also please provide an overview of your networking setup?

  1. What is the model/manufacturer of your router?

  2. Are you using any additional networking gear such as switches/access points/powerline adapters and if so what is the model/manufacturer of this equipment?

  3. Is your router up-to-date on latest firmware?


The router is an DSL-AC68U. Firmware up to date.
I use a LGS326 26-Port Gigabit Smart Switch.
I use also TPLink PLCs to transmit signal to Bluesound Nodes.

Zen Mini, router, plcs and other gear (Synology NAS, Intel NUC, some Raspberry pis, Onkyo receiver, etc) are connected to the switch.
This network has been working with Roon for years.

DSL-AC68U --> Asus DSL-AC68U

Hi @ryoanji68,

I spoke to QA and we looked over the diagnostics and there appear to be quite a few networking-related issues, specifically it looks like you’re getting Name Resolution Errors, which point to having a sub-par DNS server setup.

Can you confirm the following:

  1. Are you able to properly play TIDAL/Qobuz content?

  2. Are you able to search for tracks in Roon without any issues?

  3. If you have another PC you could try to temporarily use as the Roon Core, can you please give that a try and connect it in the same way (same Ethernet cable/switch) as the Innuous Core? It would be interesting to note if this behavior only occurs on the Innuous or on other PCs when acting as the Core.


Problem is solved.
I took a look at the logs and saw the NameResolutionFailure errors, they had no sense for me. Tried your suggestions and still the same problems.

Made some additional tests and long story short: Zen Mini has two ethernet connectors, one for lan and other for streamers. I had both of them connected to the switch and that was the mistake and i completly forgot that detail.
Only lan should be connected. Plugged off the streamer cable, rebooted and everything worked fine again.

I don’t understand why this started to fail now, it has been working ok with both cables for months but anyway, problem is solved.

Thank Noris for your support, my lovely Roon is again at 100%.


Hi Juan,

Thanks for the update here! I can’t say for sure why it worked with both cables connected, but in any case, happy to hear that correcting the connection has allowed Roon to update properly.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.