Metadata Improver Halted Again

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus (10.0.0.218), Roon Version 1.7 (build 610) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Blue Curve Gateway modem, Ethernet cable to Cisco 2960 switch.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Ethernet cable to Naim NDX 2 streamer.

Description of issue

I have the same problem as many do: the metadata improver is halted and I cannot add albums to the library. I had the problem a few weeks ago. I tried re-naming the cache - didn’t work. Then the last update seemed to have fixed it. But the problem has returned. Cleaning up the library has not worked either. I run a Roon Nucleus and have restarted it after attempting every fix.

@dylan suggested I reboot the core from the administration interface 12 days ago and that resolved the issue temporarily. But yesterday the issue returned and rebooting has not helped.

Hi @Michael_Kurtz,

Did this issue happen only after logging into the Nucleus Core after using another Core for some time?
Does a reboot of RoonServer in the Nucleus Web UI help?

Hi Noris,

Thanks for getting back to me - I really appreciate it. I only have the one Core. And no: rebooting from the UI doesn’t work.

Hello @noris: is there any further help you can give me?

Hi @Michael_Kurtz,

Thank you for confirming that rebooting from the WebUI does not help.
I am looking over your setup details once more:

From what I can tell, this seems to be a managed switch, can you confirm?

Managed switches have been known to cause issues with Roon unless fine-tuned, as mentioned in our Networking Best Practices Guide.

Do you by any chance have a consumer grade router and un-managed switch you can try to plug the Nucleus into instead? If so, can you please give this a try and let me know if it helps?

Hi @noris, yes: the Cisco is a managed switch, although I use it unmanaged, as many Naim streamer owners do. Having looked on the Naim community forum, I see other Nucleus owners have had similar issues. I have now connected the Nucleus to the network via an old, unmanaged switch, which is connected to the router. This seems to have solved the problem, at least for now. Thanks so much for your attention to this - and for bringing my attention to the issue with the Cisco switch. Roon is a wonderful product and I am so happy to be able to access all its functionalities again.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.