Metadata Improver: Halted. Roon needs a software update. (new)

I re booted my core to fix it. Worth a try

Dear Chris, I reboot the core almost every day. Unfortunately, that does not fix the issue.

I am also getting this message all of a sudden this morning after a restart. The latest scheduled backup was performed 2 days ago.

Update: after a restart, the symptom disappeared. Lately, I feel like walking on thin ice.

I am having the same issue. Running ROCK on a NUC8i5. I also get an endless spinning circle in the upper right hand of the window indicating that it’s working on something…but it never goes away.

Hello all, thanks for your reports! Most of the users who have experienced this issue in the past have been resolved by a reboot. Please give this a try and let me know if this helps.

I rebooted my ROCK last night, and the issue has resolved.

Hi,

in my case, a restart of the Antipodes CX server hardware does not affect the issue.
The problem is still present.

When I shut down the roon server software, clear the roon cache and start the server again, the message does not show again for a few hours and comes back then. So the problem is still not solved.

One more thing: I realized that when the fault message is shown, then I can’t search for new Tidal or Qobuz content that is not yet in my library.
Yesterday I was not able to find a single Joni Mitchell album.
Today after restart of the roon server, I was able to find about 85 albums…

Could you post a screenshot of the Roon Setttings/Storage page?

Dear Tony,

I visit family today and will be back home on Saturday.
I will upload the Screenshot after my return.

Best, Matthias

Dear Tony, please see attached my storage settings:

You have the same folder in twice. I would expect you are seeing every album doubled. Disable one of them using the three dots to the right.

1 Like

Hi Ged, thanks for the hint. I disabled one of them:

Since I stopped the rron server and cleared the roon server cache, the fault message did not yet reappear.
But stopping the server and clearing cache did only fix the issue for some hours in the past.

I will try if your hint did fix the issue and reply shortly.

Thanks!

Hi Ged, I just realized, I have a different issue while playing a playlist now:

Disabling the upper folder leads to this:

Disabling the lower folder leads to this:

Do you know, how to fix this?

Try reanalysing. Settings, storage, three dots, force rescan.

Hi Ged, unfortunately, I read your reply too late:
I alrfeady fixed the broken links by hand (added the same tracks again and removed the wrong linked ones).
I hope, that’s it and my problem is solved. Thanks again.

1 Like

Hi Ged, hi Tony,

the fault message did not yet come again.
I’m not 100% certain at the moment but I think, the problem is solved…

Thanks for your great support!

1 Like

Hello @Matthias_Heberle, and thanks again for your report. Please let us know if you need help again!

I had this problem a few weeks ago and resolved it by rebooting. Just tried to use Roon and the same behavior occurred:

  1. Couldn’t use Roon on either my iPhone nor my Macbook without logging in again, deauthorizing the “old” library.

  2. Then I received the following message when clicking the red triangle in the upper right part of the screen:

Was this related to Roon being down b/c of Google Cloud issue? Should I reboot or would it be helpful to see diagnostic logs?

Thx.

Joining this late … @Ged_Hickman1 told you what I was looking for and would have said. On Antipodes servers Music Folder points to /storage and its sub-folders. By adding the Watched Folder /storage/music Roon was scanning the same library twice and duplicating the entries.

I suggest you also check Settings/Library/Library Maintenance/Clean Up Library and clean up if needed.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.