Metadata Improver: Halted. Roon needs a software update. (Still not fixed)

Hi @Matthias_Heberle,

A Metadata Improver error may also occur due to other factors, please see:

Are you by any chance using any VPNs / VOIP systems?

Hi Noris,

I am using a unitymedia account, which is a cable account (measured 412 Mbit down / 20 Mbit up / 22 ms latency). I am using only IPv4 and disabled IPv6 at the moment.
My phone @home runs over the same cable which is VoIP but we barely use it ever (about 1 call per month).
I do not use any VPNs.

Regarding the routers firewall: I did not configure anything special there. But I would expect roon not to work at all if it would be wrong firewall settings there…or am I wrong?

I don’t know about the firewall and/or amtivirus software on my Antipodes CX server. I can’t configure anything like this for the server (on which my only core runs).

Sincy I changed my roon password two days ago, the message did not yet show again but I had some days without message earlier and it still came back then…

Best Regards
Matthias

The message keeps coming up.

What else can I try?

If you have not already I would suggest deleting Roons cache folder as it will rebuild itself afterwards. Stop Roon core locate folder delete or just rename it , then restart Roon. This worked for me when I had the issue on ROCak and it never came back after this. Not sure how you access this from Antipodes though.

Hi,

thanks for your reply. I did that several times. It fixes the issue for the moment. But the message keeps coming up again.
Sometimes some hours later, sometimes some days later…

Best
Matthias

Sorry to hear that… Then i suppose this might indicate an issue with your VOIP setup. Somethkng obviously either messes up the communication or deauthorizes your Core…
But @support should see that fine when they enable diagnostics for your account.

Hi Mikael,

I did not see the message yesterday but today after I started the Antipodes server.
The telephone has not been used during the past few days…but maybe you are still right.

Hope the support can help me.

Best
Matthias

Hi @Matthias_Heberle,

If you see this message again, you can try to reboot just RoonServer via the Antipodes Web Interface to see if that helps. We have an active investigation as to why this error occurs for users, but it should go away after some time.

If you are seeing more serious symptoms such as dropouts or playback failures, please let me know, as the metadata improver error might just be a side-effect of network issues.

Having the Core connected to a repeater also could be part of the issue, you can try to bypass this as a test.

If you have not done so yet, I would also advise you change the default DNS servers on the router to Cloudflare DNS, Quad9 or Google DNS. You may want to call up the ISP first to see if changing the DNS will have any impact on the VOIP service though.

Hi Noris, thanks for your reply.

The message came up again this morning.

I restarted the just the roon server, not the Antipodes hardware and the message is gone temporarily.
But I did that several times before and it keeps coming up again after some use.

Besides of the occasional lags for search results (happens several times a day and results need up to one minutes to show then), I do not have any dropouts or playback failures.

I will connect the Antipodes server to a Zyxel switch instead of connecting it to the repeater and see if wiring per cable changes the behaviour.

DNS was by default the providers servers. I just changed to the suggested Google DNS.

Best Regards
Matthias

1 Like

Problem not solved yet. The only thing I did not yet do is bypassing the repeater.

I will try this out next step…

1 Like

Now I included all hints regarding my topic:

  • I have only one core and only one iOS remote
  • I changed the credentials for my roon account
  • I changed the credentials for my Tidal account
  • I changed the credentials for my Qobuz account
  • I don’t use any VPNs
  • I cleared Roon cache several times
  • I do only have one local link to music data configured
  • I bypassed the repeater and connected the Antipodes CX to my router by LAN cable (100 MBit), there is one switch between the router and the Antipodes CX
  • I changed the DNS address to the Google DNS

The issue is still not solved. The Metadata Improver message keeps coming up again…
Any more ideas?

Sorry for your troubles. I’m out of ideas except one, and that is to elliminate the VOIP configuration, but not sure how to. A borrowed extra router for just your music network, configured to a different subnet than your regular net.

Can you not use a PC and install Roon there and test if Roon runs ok. Then you would know where to search. I have no idea what Antipodes does or is, but it seem that it adds an extra layer of software in between as it has buttons for cache clearance that I have not seen on the PC and wonder why one would need a button for that if all works well…

Hi @Matthias_Heberle,

We are still investigating this issue on our end, but I noticed you mentioned this:

Are you using an older CAT5 Ethernet cable that is limited to 100Mb (and is not a Gigabit Cable)?

Hi Noris,

good to read from you, because I don’t know, how to go on now.
I do not have a spare Windows PC to install the roon software on.

My Antipodes Server is a Server for music purposes. It is connected to my DAC by USB. So it has to be placed in the living room, where my HiFi-setup is located.

Regarding the LAN-cable:
I live in a rental flat. The cables in the walls are 4-pin twisted pair cables.
So they can only be used as 100 MBit LAN cables.

The current configuration is:
Router - 10/100 MBit (4-pin) cable - 10/100/1000 MBit switch - 10/100/1000 MBit (8-pin) CAT7 cable - Antipodes server

The former configuration was:

Router - WIFI 5 GHz, 1100 MBit - MESH Repeater - 10/100/1000 MBit (8-pin) CAT7 cable - Antipodes server

Both configurations showed the same issue regarding Metadata improver…
And none of the other hard-wired LAN-devices (1 CD-Player, 2 Smart TVs) do have issues with the LAN-cables in the walls.

I have also a Antípodes CX server and I am facing exactly the same problem.
Any solution to solve it?

A post was split to a new topic: Returning metadata improver error

Hi @all,

I thought this issue has been solved with one of the recent roon updates because I don’t see the warning any more.
I did not change anything, but I have not seen the message for about two months or so.

Best Regards
Matthias

No it has NOT been fixed.


Extremely glacial reactions.
Every 3 to 5 days an answer and then you have to push again.
Very unsatisfying :roll_eyes:

1 Like

So, @support, what’s the fix? The warning triangle appeared for me 3 days ago - several core reboots, router reboots, log out, log in, select core, nothing helped. Whats next, I’ve run out of things to reboot?

Update: Manually setting IP, gateway, and 1.1.1.1 for DNS in the core admin webpage, then rebooting fixed it. I’d prefer not to have to do this though. Curiously, reverting back to DHCP didn’t bring the warning triangle back - perhaps it takes a few days :joy:

1 Like