Metadata Improver on SonicTransporter

I get this problem and it is reproducible. When I go on holiday, I switch off my Linn Klimax DSM 2021 and switch off my Sonictransporter running the latest stable build. When I switch all on again I get the metadata improver error message. Radio stations are unavailable and discography invisible. System reboot of Sonictransporter resolves the issue. P.S. Logging out and in to Qobuz has no effect.

Hello @William_McKinney ,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Typically this issue can be caused by a VPN or a VOIP system running on the network, are you by any chance using either of these services?

Hi @noris thanks for getting back to me. Below are my system details. I am not using a VPN.

  • Sonictransporter V2.5 with integrated SSD
    Roon Server Version:* 1.8 (build 814) stable
    Roon Server Database Size:* 3.7G
    Roon Server Cache Size:* 114M
    Filesystem:* /storage
    Size:* 858G
    Used:* 260G
    Available:* 554G

  • iPhone 12 pro Max 256GB, 170GB available iOS 14.7.1

  • iPad pro 3. Gen 256GB, 212GB available iOS 14.7.1

  • LAN Ethernet connection from Sonictransporter to Linn Klimax DS/3 2021 Exakt System Hub via Cisco Catalyst 2960 switch and FritzBox! Router software version 07.28 download speed 61.7 Mbit/s upload speed 12.4 Mbit/s

  • Linn Klimax DS/3 2021 Exakt System Hub via Exakt to active Linn Akubarik Exakt speakers

  • Library is on Sonictransporter (see above). Streaming service via Qobuz Sublime subscription

Hello @William_McKinney ,

Thank you for sharing those setup details!

We have just released a new version of Roon, can you please confirm if you are still seeing this issue at the present time?

If so, can you please confirm if you bypass the Cisco switch and connect directly to your router, do you still notice the error?

Managed switches have sometimes caused networking issues in Roon, as mentioned in our Networking Best Practices Guide:

Managed Switches

Managed switches can be very robust, but they are often designed for professional installation, so in many cases the out-of-box configuration is not right. If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic. If in doubt about any of this, try temporarily replacing your managed switch with a “dumb” switch to see if things improve.

Thanks!

Hi, I haven’t seen the message in a while but will get back to you if it reappears.

2 Likes

Hey @William_McKinney,

It’s been about a month since this thread was last active. I wanted to follow up and see if the issue has been resolved for good? Fingers crossed :crossed_fingers:

1 Like

Hi, well I haven‘t switched the Sonictransporter off in a while but I will try doing so in the next few days and will report back

1 Like

Update: no further occurrences

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.