"Metadata improver: paused" warning


I often see a warning triangle in Roon Remotes, and when I click on it, the message “Metadata improver: paused”. I’m using Roon since spring and didn’t have any problems like this at first.

The message first showed up some two months ago or so. Since then, the message is sometimes there and sometimes isn’t, but it’s there more often than not.

Note that the computer the Roon core runs on isn’t switched on 24/7, only when I use it (rather seldom) or when I want to use Roon. In the meantime, the computer is put to sleep, not shut down. Could it be that there’s simply some timer that checks when the last successful attempt was, which might have been days ago, because the computer was sleeping?

My setup:
Core: Arch Linux (more or less current, updated every 1-2 weeks), Intel core i3-6100, 16GB RAM, Roon version 1.8 (850)
Network: Fritz!Box 7490 router, Fritz!OS 7.28, stable DSL with 63 MBit down/13 MBit up, core on cable (GigaBit EtherNet) via TP-LINK TL-SG1008D switch
Library: Stored on Synology DS413 NAS connected to the same switch

Best regards, Christian

P.S.: I don’t have any problems with stuff like search, daily mixes etc., so there should be access to Roon’s servers, shouldn’t there?

I’ve moved your post from an old thread to a new post in the Support category. Someone from the Support team will be along after the weekend to pick up your issue.

1 Like

Any news on the topic?

normally this is because of a failure to connect to Roon’s Cloud Services as Roon starts

maybe try

switch everything off including the network components

wait 5 mins for all capacitors et to “drain”

start each component in turn waiting until the start up is complete , don’t rush it.

I restart daily in summer and this is how I do it , RUSH and it fails … :smiling_imp:

might help, can’t hurt …

Another incident from yesterday which maybe has the same roots:

I tried to add a Qobuz album I was currently listening to. As often, I only got the spinner for minutes. When I went to the album view, the album was there, but without a thumbnail, it looked like one of those local albums Roon doesn’t recognize. Going back to the screen where I added the album, ten minutes later still the spinner showed.

I deleted the album from the library and tried again (this time not playing the album at the same time), with the same result. At some point, suddenly the popup showed up that is also shown when I click on the warning triangle. It told me that Roon had imported the 43 songs of the album and was currently trying to fetch the metadata for the album.

I hoped that a restart of the Roonserver service might help and did so. Afterwards, I deleted the album from the library again (might have been before that, too), and after the Roon service was up again, I tried to add the album again. Still the spinner, nothing more happened even half an hour afterwards. But now, the album wasn’t added to my library at all, it never showed up there. I tried again several times with the same result, including more than 8 hours later.

This morning, I did an Arch Linux update and rebooted my PC where the Roon core runs on. Afterwards, I could add the album without problems.

I’m pretty sure that this is not a networking problem on my side, at least if it’s not something like ports that have to be opened in the router or similar. My internet is rock solid and fast.

My guess is that it’s either Roon servers being slow/unreachable, or, more probably, as there seem to be many without this problem including myself before fall, that it’s some kind of software problem that applies only to few special situations. I’d like to find out what those special situations are, in order to fix them here or be able help the Roon devs fix them in the software.

I looked in the logs and tried to find differences between yesterday’s first attempt to add the album to the library and today’s attempt after restarting the core and its host.

In both cases, all the files for the album were imported with lines like

12/03 07:29:49 Debug: [music/storage] importing file [...] from Qobuz Storage Library

But only this morning, this line followed:

12/03 07:29:49 Trace: [identification] <237871> Identifying album [...] with 43 tracks

It seems that yesterday, the Roon core didn’t even try to identify the album. Searching for “identification” in yesterday’s log didn’t yield a single result. But there are no obvious errors, either.

Well, I don’t know enough about Roon’s internals to say if that is of any relevance, but maybe it helps pinning down the problem?

1 Like

Just to mention that here, too:

This problem seems to be fixed since the Roon Core version that came before this week‘s version. Must have been 1.8 build 898, I think.

I hesitated to post that because for the problem to show up, the computer with the Core had to be sleeping for at least one or two days, which wasn’t often the case, lately. But it seems this is really a problem of the past.

EDIT: As I can’t reply anymore, I have to edit this post: Unfortunately, I spoke too soon. The red triangle is back. :frowning: So back to restarting the roon service whenever the triangle shows up.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.