“Metadata improver: paused” warning

Roon Core Machine

Lenovo m910q/16GB/Linux Debian 11

Networking Gear & Setup Details

Directly connected to ASUS RT-AC86U

Connected Audio Devices

Connected to Schiit Bifrost DAC via USB

Number of Tracks in Library

Approximately 10,000 tracks

Description of Issue

I keep seeing a “Metadata improver: paused” warning. The network is fine and I can ping/reach any address. Rebooting the machine doesn’t clear the error. I killed the Roon service and restarted it, and that seemed to help. I notice that it happens whenever I add files to the library.

Any ideas?

1 Like

Your Core does not feel it has been granted a license from Roon HQ.
I’m not sure about the technical details of all of this, but the remedy would be:
Go to Settings-Log out
Then chose your Core anew and log in.

This should reset your licensing and get rid of the Metadata error.

I have this on my Roon core which runs on a Qnap every time my router has been rebooted.

If my ISP (or I) reboots my router, and all other network keeps on running, my Roon Core on QNap also displays this.

When I then just restart the Roon Core on the Qnap the message disappears.

If I don’t restart my Core, the message will stay… which is kind of weird, because all network related stuff is already long back to normal and fully functional

This seems plausible. I had a network outage about a week ago, and while the machine has been rebooted since then, Roon is funny about some things; for example, how it saves its state. It was also hung up trying to add new files to the library, which indicates it was probably not communicating. In essence, the network was there, but Roon had decided that it wasn’t. I’ll try this next time I see this error.

My response was a bit simplified, there are quite a few other plausible reasons for this error to surface. Such as connectivity issues, as you mention.
Normally, it only takes a reboot of the Core to reset this though.

Why Roon Core doesn’t simply try and restart the offending component once in a while is a bug imo however…

And when you are running multiple Cores on one license, this issue surface quite often, so you learn to adress it. This is a bit of a chore as it often requires two reboots to remedy itself. Once again, why do i need to reboot the whole Core to restart this small part of Roon?

For all kinds of sensible software reasons, Roon appears to do a lot of its own housekeeping with its internal state. Even though the network came back, and everything on the network seemed to know it, Roon never seemed to accept it. I have to conclude that it was using some internal flag of its own that never got reset. It sure looks like a bug because it was continuing to operate under a false assumption; i.e., the network is down. Rebooting the host machine didn’t appear to clear that. Killing and restarting the Roon process seemed to work, though. (I’m keeping the logout/login suggestion in my back pocket as well, just in case.) I hope that there’s enough detail here for the developers to isolate the issue. It could also be an underlying Linux bug where whatever system call they used returns something ambiguous. In the meantime, it seems we have workarounds!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.