Metadata not identified

Recently albums bought from Presto Music are not identified for metadata. Never happened before, and now it happens with every album added.
Example in screenshots


You checked if the albums are in MusicBrainz and Allmusic? If not they won’t be identified. Classical is common to have poor metadata in the cloud.

I am also finding that auto-identified albums often cannot subsequently be manually identified. I want to do this because roon usually has several alternative albums that might be a better match. This also is a new development for me different than weak Classical metadata that I have not seen before. It is happening so frequently that it seems systematic.

Here is a recent example:

As you can see it is identified.

However, if a now try to manually identify this album (in case I can get a better match) then I get this:

This is not an isolated case. It is happening frequently in a way that it didn’t before.

@Butz, I recategorized this post into the Metadata support category.

Metadata of this specific album were recognized by Roon while my Tidal subscripion was active. So I guess, they must be in Roons system.

Another problem : metadata identification used to work well in Roon, with rare exceptions. Why are now all of my 4 imported albums not recognized? The titles are not exotic, strange problem.

No it just means the album is available in Tidal and therefore Roon will not show it as unidentified as it’s in a streaming service. Roon can’t use Tidals metadata as it’s theirs it can only be seen if you had the Tidal or Qobuz album in your library. It relies on Allmusic and MusicBrainz for its metadata services for your own files and the advanced metadata if it’s not in there you don’t get it identified as is your case here. Only way to make Roon not show as unidentified is to add the Tidal album and group your version with it.

Currently, I can’t reproduce the issue on my side, at least for the example you listed.

Do you get any results when you manually search for nirvana - nevermind ? I’m trying to determine whether there’s some connectivity issue at hand.

@tripleCrotchet it’s true that classical content is a bit messy sometimes. In particular, orchestra names are often in a different language. Here, I’ve entered Köln instead of Cologne, and managed to find the album. We have a ticket open for these particular cases.

As far as the OP’s issue, roon will auto-identify:

However, this is an ensemble album. Either myself or roon added the other primary artist links, I don’t remember:

Now it cannot be manually identified:

I can only get a manual identification of an already auto-identified album by a lot of trial and error with the search terms and eventually worked out that in this case I must remove all the artists except Janine Jansen:

So, my example of English translations of foreign artists does not work, the OP’s example of multiple artists does not work. There are other cases. This is a relatively frequent occurrence that an auto-identified album cannot subsequently be manually identified for a large number of possible reasons except by trial and error edits. I am noticing this as a much more frequent occurrence since recent releases. Although it is not the case with the OP’s example, the reason I want to do this is incase roon has a better match than the auto-identified match which often happens with hierarchical, multi-part Classical albums.

1 Like

Searching for Nirvana - Nevermind identifies the album (which is not in my library).
Repeating the search that you did successfully gives again no result. So what does that mean? How can I check for “connectivity issues”?


I have taken out all ensemble names except for Janine Jansen, but Roon will still not identify metadata for this album. Also made trial and error versions , switching Artist and Album names which identified this album, however, i can not select the album with a double click.

I just use a single click. Does that work?

Single click / double click/ right click: nothing works

Did you try removing the album from your library then “clean up library” in settings->library. Then re-boot, your core and roon and then adding the album back in? Sometimes if you have been adding and editing albums roon gets confused and you need to start again.

Followed your suggestion step by step: album remains unidentified.

For what it’s worth I’m having the same issue, also with classical albums. Or at least I haven’ seen this happen with any other genres to date.

I often find Roon won’t be able to ID new classical albums. In the past you could click on “Unidentified” and it would open the editing page. Then you clicked on the Identify Album button and Roon would give you a screen or two of possible matches. Probably 75% of the time the correct album would be in that list.

If you don’t have a match there you can move from there to a search screen that lets you change the Artist and Album information in case your file based data doesn’t match the cloud data.

Now however after clicking on the Identify button it first gives you the Roon “processing” symbol. After a few seconds it gives up and goes straight to the search screen where it keeps “processing”. And in every case when it is done it won’t give me any guesses as to what it might be, it just says “No results found”.

I’ve re-booted, no results. Roon is properly identifying other albums I’ve added including some classical ones. So I don’t believe it is a connection issue.

One of the albums with this issue I was just able to fix by changing the title of the album slightly and searching again. That brought up a list of albums and the one I needed was included. So the data is there, Roon is just not handling it properly at the initial search phase.

To be specific I kept the name of the performing group and just removed the composer name from the title- from “Mozart: Flute Quartets” to just “Flute Quartets”. It gave me about 8-10 albums from the group and the correct one was among them.

FYI- I’m running my Roon Core on a Mac mini, a late 2020 model with the M1 chip.

1 Like

Could you please post the exact album, and the whole/exact text that is searched in the identification wizzard (both the artist and album section)? This way, we can try to get to the root of the problem.

@Butz Thank you for checking the proposed queries. I’m unable to reproduce the non-clicking issue on albums, but I’ve asked our QA team to have a look at it.

Tried another ID-search which after many trial and error entries showed the album searched- again, however, the album will not be taken over into the library (Clicking issue")



I’ve been finding this fairly frequently in the past couple of days – very very rare before that. Bears watching

The album I was able to resolve the issue on was “Mozart: Flute Quartets” by Ardinghello Ensemble.

Label is Brilliant Classics.

Again to get this one to work I had to remove “Mozart:” from the title after which the search function gave me a series of titles by Ardinghello Ensemble, one of which was the correct title.

Here are a couple that are not working. Biber: Mystery (Rosary) Sonatas by Amandine Beyer & Gli Incogniti issued by Harmonia Mundi. It has been unidentified in my library for about three weeks.

Another one is Per Nørgård: Orchestral Works by Bergen Philharmonic Orchestra & John Storgårds
issued by BIS:

I have been unable to get either of these two to work despite trying variations of names similar to what worked on the Mozart album. I also tried to remove the non-standard characters, replacing things like å but that didn’t make any difference and I note that some of these don’t have unusual characters and don’t work.

I have more but some are from smaller classical labels that sometimes take a long time to upload metadata so they might just be a result of that. But these two are major labels that I haven’t seen problems with before this month.