microRendu Device Volume

Is there some way to setup a microRendu so Roon can control the volume? Under Device Setup I can choose Device Volume but when I click the Speaker icon when playing music it still says Volume control is Fixed. The equipment is in a different room from where I’m listening and I’d like to replace the Squeezebox currently driving the system with one of my extra Rendu’s.

Device volume would be handled by the DAC connected to the microRendu.
If your DAC doesn’t support device volume, you can use DSP volume in device setup.

Thanks for the response. I’d like to use a Schiit Gumby which apparently doesn’t support device volume and I’m not sure what you mean by DSP volume as I don’t see any options under device setup. Thanks again for your help.

In device setup go to Device volume control set to DSP Volume , it will be on Device volume by default. Then it will use Roons DSP volume control on the endpoint. In some cases its not available not sure about the microrendu.

Via this way you get a lot of harmonic distortion. The best way to handle volume is via the amplifier and that one is of course not controlled by Roon.

Thanks, DSP Volume doesn’t show as a choice with any of my DACs so I guess I’ll have to come up with another plan.

It’s not the DAC that does DSP volume it’s the endpoint itself.

That’s the way I do volume with both my main and headphone rigs but in this setup I’m asking about, the receiver driving the house system is in the laundry room so using it’s volume control isn’t an option.

Would you please care to elaborate?

you can try this one yourself. Cut down your amplifier by 6 dB and correct the volume with DSP and you will notice that this has a negative impact on the sound quality. At my setup via this way SQ is not ok when forcing the DSP too much up and down

In any event, it not a choice with any of the Rendu’s.

If it were applicable with the OP’s microRendu, and I actually don’t yet understand why he’s missing the option here, we’d be attenuating the output, not boosting.
So, no distortion due to digital clipping would be introduced.

Roon’s DSP volume control is done using 64 bit precision.
So, even if you’d attenuate by 96 dB, the CD’s full 16 bit resolution, there are still 48 bits left for math to not introduce distortion here, either.

For whatever the reason, it’s not a choice with any of my Rendu’s.

Based on my measurements, this is not accurate. However, signal to noise ratio is reduced slightly when using DSP volume.

For me, the most insidious aspect of DSP volume is that it’s implemented on the endpoint rather than on Core, resulting in up to a 100% increase in endpoint CPU usage. If you are using volume leveling or DSP, this often results in the signal being dithered once on Core and again on the endpoint, although these details are not revealed in the Signal Path.

Interesting. I don’t have a Sonore {optical,micro,ultra}Rendu to test. I suppose you’ll just have to keep using the remote control on your amplifier.

I have a Sonore Ultra rendu, the only way I could find was to increase/ decrease volume by adjusting the dB level for all frequencies. But the result was that way I decided to use the old classic amp volume button.

Oh by the way, I changed my Sonore powersupply by a better one, the best I could get, designer said it is better then SBooster.

6 Volt, 1 ampere linear powersupply, gave these specs and got this high end LPS, this is awesome :sunglasses:


I have a microRendu connected to a Mytek Liberty DAC connected to some active speakers. It is set to Device Volume and I am able to use DSP volume to attenuate the volume. I’d theoretically prefer not to because of the effect on SNR, but as a practical matter it works fine.

1 Like

As shown in the screen capture earlier in this thread, I do not get DSP Volume as a choice.

Right. Neither do I, as you can see. But if you set It to Device Volume you should be able to use the volume slider (you can see mine is at -3db) to attenuate the volume. The trick is to set the volume on your DAC or amp as high as you ordinarily want it, then step it down from there.