microRendu - Geek Out DAC, static with DSD [Fixed]

Jesus - I’m getting pure static on my DSD files using a Geek Out DAC. Is this what I should be seeing on the setup panel, such that I should be getting correct Native DSD output?

Go to Settings/RoonReady and check the box next to, “If your DAC supports DSD-over-PCM (DoP) enable this to send PCM encoded DSD to your DAC.” This will send DoP to DACs that do not support native DSD and it will send native DSD to DACs that are supported.

That option was already selected.

While playing music that produces the noise go to Apps / DAC Diagnostics on the unit and post all the information from that page. Also, let me know what sample rate your are playing.

This is DSD 64.

LH Labs Geek Out HD Audio 1V5 at usb-ci_hdrc.1-1.1, high speed : USB Audio

  Status: Running
    Interface = 1
    Altset = 2
    Packet Size = 118
    Momentary freq = 88199 Hz (0xb.0660)
    Feedback Format = 16.16
  Interface 1
    Altset 1
    Format: S32_LE
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000
    Data packet interval: 125 us
  Interface 1
    Altset 2
    Format: SPECIAL DSD_U32_BE
    Channels: 2
    Endpoint: 1 OUT (ASYNC)
    Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000
    Data packet interval: 125 us
format: DSD_U32_BE
subformat: STD
channels: 2
rate: 88200 (88200/1)
period_size: 2205
buffer_size: 8820

I need the information above that as well. This is an example:
DAC description: Audio Advantage MicroII 0d8c:0103

Here you go:

DAC description: Geek Out HD Audio 1V5 2522:0007

Shifted the discussion into this separate thread :slight_smile:

The information you provided looks okay to me. However, I don’t see that device listed on their website. Which one of these is your DAC?
Geek Out V2, Geek Out V2∞, Geek Out V2+, Geek Out V2+∞

None of those.

It’s the original v1 Geek Out 720.

The native DSD driver was written for the Geek Out V2 series so that might be the issue. See if there is a firmware update for your unit. It looks like it supports the correct format, but something is not right on it…

You’re probably right. It seems I have the latest driver, so perhaps I just need to be using DoP. Except the DoP option is not available to me in Roon now.

Is there something you need to do on your end to enable that?

Unfortunately, that device has the same USB IDs as the newer devices and Roon thinks it supports native DSD. Check with LH to verify if that device supports DSD_U32_BE format for native DSD.

Go to the GUI and update your unit from Apps / Software Manager. Then go to Settings / RoonReady and select DoP output from the new DSD Support dropdown menu.

Problem solved; thanks!

Suggestion: iterate the version numbering, so that the updating becomes more clear.

Each time I’ve updated, the “current” and “latest” versions are exactly the same (“2.1”). Would be more clear if they were different: say “2.10” and “2.11”.

These are not really updates and rather quick fixes. When we have a bunch of these we will wrap them up into a new version number.

Thanks Jesus,

Lovely to see such quick and efficient response to user difficulties.

I know, but the UI is confusing.

It’s my pleasure…