Migrated Core, NAS Storage, Playlists Now (Mostly) Empty

Hi @rcrawley ,

Thanks for those additional details, I have forwarded your remarks to the QA team. Thanks in advance for your patience while they review your case once more :hourglass_flowing_sand: .

Hi @noris, just checking back on any progress. This process also made me wonder if there’s another way to export my playlists from the still-working original NAS Roon server in a format that I can pass into the new Mac Roon Server as an import. It looks like my only options for exporting are either text files or exporting with the music files themselves, correct? No way to export just the playlists from one server and import them into another? I thought there may be a way since the storage locations are the same.

I am at a point where I think I’m going to have to manually rebuild them, but after exporting CSVs for all my playlists on the working Roon server, I’m looking at manually dealing with 14k tracks in those playlists, and clicking through 14k times to re-add manually doesn’t sound fun. :slight_smile:


Hi @rcrawley ,

I checked with QA on this and they have been unable to reproduce the issue in the lab, the next step would be to take a look at the database itself.

Can you please exit out of Roon and then zip up the contents of your Core RoonServer (or Roon folder if you’re not running headless anymore) and upload it here?


Please let me know once uploaded.

Do you by any chance have Soundiiz and streaming service? That might help while we look into the database.

Thanks @noris. I’ll work on the DB part. re: Soundiiz, yes, I do use it and also have Tidal. But I don’t see Roon as option on Soundiiz. Am I missing it?

It is not a side-bar option, but rather you can import the Roon playlist contents:

Note: CSV Export is now supported too (suggested method).

Thanks @noris. I was able to import my playlists to Soundiiz from the good Roon Core but I’m not seeing an option to export them back out to the Roon Core with the busted playlists? My goal is to migrate the playlists from the NAS to the MBP, and that doesn’t appear to be an option as best I can tell (unless I’m missing something), natively or via Soundiiz.

@rcrawley how many of your folder names or files contain question marks, quote marks, slashes, or contain a terminating period? Some of this reminds me of issues I had with items showing up in playlists before I fixed those problems.

Hey @rcrawley ,

You won’t need to export them, after you import them to TIDAL/Qobuz, they should automatically appear after your next TIDAL/Qobuz sync. This way as long as you sign in with the same TIDAL/Qobuz account, they’ll automatically be downloaded from the TIDAL/Qobuz cloud.

13 folders contain quotation marks, none contain question marks, none contain slashes (in either direction), and none contain terminating periods (my auto-backup software on the NAS doesn’t like trailing periods). Good thought, but none of those dir names have changed since original import.

Resurrecting this thread because I’ve now been able to reliably reproduce the issue at will. As part of this thread – RoonServer Stuck Initializing on new Mac Installation, Logs Showing Critical Exception [Ticket In] - #67 by Matt_Armstrong – I just made a fresh backup of my DB from Roon running on my NAS and immediately imported into “full” Roon running on a freshly wiped MacBookPro. As soon as I imported the fresh DB backup I immediately checked my Playlists and saw that they’re back to the “only 5” issue that I’ve been having since originally reporting the issue. I removed Roon from the MBP, removed the Library dir, and tested the process again, same result. Everything else in the DB restore seems to be correct. Rinse and repeat over and over.

The new MBP also has a complete local copy of my music files; I’m no longer mounting the NAS from the MBP and storing all music locally to remove that as an issue. I also tried both restoring the DB first and then changing my storage locations to point to the local drive as well as adding the local storage to Roon first and then restoring the DB, both with the same result.

To compare, here’s a cap of my correct playlists on the NAS core compared to the incorrect playlists on the MPB, taken at the same time. It’s literally the same DB and same set of local music; the only difference is one core is on a Synology and one core is on a MBP.

Good playlists on NAS:

Bad playlists on MBP:

Hey @rcrawley ,

Thanks for the additional information here, and for letting us know that you are able to reproduce reliably now.

Have you had a chance to upload this database for review? I’m wondering what the playlists look like when loaded up on our end.

How does the current path of the music files look like, can you share any screenshots?

Let me know when you have a chance, thanks!

Hi @noris. I’ve been doing a lot of testing over the past two weeks, with many NAS DB backups and restores on the MBP, and here’s where I am at the moment:

  • Per a question from the original conversation, I renamed all of the playlists on the original NAS by removing the [Roon] prefix just to rule it out. I then took a fresh DB backup and have been using that as my source for restoring.

  • Without the [Roon] prefix, the playlists were correct for a few days after a restore but eventually fell back to the recurring “5 songs” problems. It’s probably a red herring but with this test I noticed that the playlists didn’t get screwed up until after I enabled Tidal integration (where I also have a bunch of playlists). In that test I wasn’t connected to Tidal for the first few days, and then not long after enabling Tidal in Roon I noticed the playlists went back to the problem state.

  • Strangely, without completely removing Roon no amount of DB restores from the clean one I made from the NAS made any difference with the playlist issue. I had to completely remove my Roon core (including everything in ~/Library) and re-install, then re-restore the DB to get back to a truly clean state. That was a really weird discovery; I assumed a DB restore would wipe the existing DB first but that doesn’t look to be the case.

  • Right now I’ve been running on a clean DB restore for a few days and still in the good playlist state, but I also haven’t enabled Tidal integration. I’m going to let this one sit for a few weeks w/o Tidal to see if that really makes a difference.

I haven’t had a chance to do that yet when I’m in the failed “5 songs” state. The next time I get back to it I’ll zip up the Roon contents and send them your way.

@noris The playlists have again revered to the “Only 5” issue sometime today. I looked through logs and nothing jumped out, and nothing changed today on my end (still no Tidal, I didn’t add any music or change any of the DB today), I just saw it had reverted sometime between Noon at 9:00 PM my time. I just tar’d & gz’d the entire RoonServer dir and the resulting tar.gz is 3.4GB. Can I upload a file that big? Thanks!

1 Like

Hey @rcrawley ,

Yes, you can upload the database to a folder I created for you here and let me know afterward:

Though please note that it may take some time for QA to look this over.

@noris I’ve just uploaded the full library. Let me know if you need anything else.

FWIW, I’m now back to a point where even restores (including completely removing RoonServer and re-installing then restoring) aren’t working to reset the playlists. No matter what I do restoring doesn’t reset the playlists. :worried:

1 Like

@noris One more data point that I just noticed. I create playlists for greatest hits and I just noticed that all of them except one are empty. No idea why Hall & Oates is fine while the rest are all empty, but I thought it might help your team see the differences between empty and not empty playlists in the DB. :man_shrugging: Thx again!

Screen Shot 2022-08-04 at 12.06.23 PM

1 Like

@noris Just pinging this thread so the support ticket stays open. :slight_smile: Thanks!

Tested with 2.0 and had the same result but caught it happening this time and have full logs to share. Can I post them to the same URL as I’ve shared other details with this issue?

Here’s what I did and what I saw:

  • Upgraded the stable NAS core to 2.0, playlists were working as expected (they always do on the NAS)
  • Make a snapshot backup of the DB
  • Did a fully clean and fresh install of 2.0 on the MBP
  • Restored the 2.0 snapshot from the NAS onto the MBP
  • Remapped storage locations after restore to local USB storage (music on the MBP core is coming from a filesystem clone of the NAS on local USB storage)
  • Check playlists, were complete and working after DB restore on the MBP
  • Stopped Core on the NAS so only version of Core on the network is the MBP
  • Roon 2.0 ran great on the MBP for a few days
  • This morning started seeing frequent “Waiting for Roon Core…” messages when playing an album (not from a playlist)
  • Restarted Core on the MBP, “Waiting for Roon Core…” messages stopped and played albums fine
  • Checked playlists, now reverted to the “5 songs” playlists

They seem to have flipped immediately after stopping/starting the Core on the MBP. Only log entries after the restart that I could find:

% grep -i playlist RoonServer_log.txt
09/25 07:38:22 Info: [playlistdb] opened. migration version = 1 current version = 1
09/25 07:38:46 Trace: [storage] [directory] Begin queuing fs events, ignoreitunes: True, ignoreplaylists: True
09/25 07:38:46 Trace: [storage] [directory] Begin queuing fs events, ignoreitunes: True, ignoreplaylists: True
09/25 07:38:47 Trace: [storage] [directory] Begin queuing fs events, ignoreitunes: True, ignoreplaylists: True

I’m not sure how to affect “ignoreitunes” to test setting it to False, beyond selecting “Yes” in Storage → Location → Edit → Import iTunes playlists", but I have confirmed I have no XML files in my Roon storage locations.

Finally gave up on RoonCore running successfully on MacOS, rebuilt the MBP running Ubuntu 22 a bit over two weeks ago. So far, so good. I hope I don’t jinx it but playlists are still complete and fully functioning after going through the same Backup NAS → Restore DB on MBP process as outlined above for MacOS. It’s also been much more stable on Ubuntu; no “Waiting for Roon Core” issues locally in the house (I still see them with Arc but I’m chalking that up to an Arc issue since I don’t see the same on the local network). Assuming this holds, it looks like a pointer to something going on with RoonCore and DB management just on MacOS.

If anything changes over the next few weeks I’ll update this thread.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.