Migrating files with custom file info to new location didn’t work as expected

Core Machine (Operating system/System info/Roon build number)

i7 PC running the latest Win 10. Roon 1.8 build 764

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

TEXT GOES HERE

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

TEXT GOES HERE

Description Of Issue
I’ve been adding a lot of large files from DTS to FLAC conversions and since they are mostly not identifiable by Roon, I’ve been editing the album artist, the album art, fixing issues, and fixing the file name to include the file specs. Having done all of that, I filled up my d: drive, so I decided to copy all of these large files to my external drive so I have more space on my d: drive. I pointed the storage settings to this new external folder and copied the 92 surround albums from the d: drive to the new folder before I delete old location. Roon forgot all of the custom info I put in for these files when I copied them. How can I migrate these files and maintain all of the work I did?

No response so far. I have tried over and over to relocate these files and maintain the data that I fixed and entered for the albums. Roon won’t transfer or won’t preserve the data. I have gone over Roons procedure repeatedly and or just won’t migrate my data. HELP!!!

Does this help?

Blackjack, Thank you for the response. That’s not exactly the first thing I tried, but I deleted the new unidentifiable files and the old files were still in good shape. I then followed this exact procedure, I turned off Roon, copied the files to the new location, hid the old folders, and restarted Roon. Roon won’t carry over the extensive changes I made. I’m at a loss.

What do you mean? What have you done?

The critical part from the FAQ as I understand it is:

  1. In Roon’s Settings > Storage, edit the folders disabled in step 1 and change the folder location and re-enable it.

Use 3-dots menu Edit to do that.

I have basically a higher level folder and subdirectories by artist, but this one is called 5.1 mixes and has 92 files in it. I don’t see a way to edit this. I tried to use disable paths but it still sees the directory. What I did do is use an app called Wise Folder Hider to hide the folder, after I copied the files over to the new directory. If there is a way to do this differently, I’m not seeing it.

I’m thinking there is a bug in the migration process. I just noticed that Jesse is reporting a very similar issue as of 16 hours ago.

I think there is no help if you put them in a different storage location (watched folder).

The folder that I moved the files to is a watched folder. If I turn them off in one folder then turn them on on another folder after the files are settled Roon should treat them as files it recognizes, not as newly imported files.

Hi @Scott_Davison

Do you have a backup from before this process? If so, here’s what you’ll want to do:

  • Restore the backup
  • Go to Settings > Storage and remove the existing folders
  • Add the new folders

This should do what you need.

Hi Dylan,
I’m a little paranoid. My backup is every 4 days. My last one is Mar 29. My oldest one is Mar 21 which is 1 day after I reported this issue. It says I will permanently overwrite any changes made since the backup… What does that include? I have added new songs and albums but not done any custom editing on the latest adds. My 5.1 Mixes file is still intact in the original location and the custom edits I did are still there. I had created a playlist and added each of these recordings to the playlist, but it seems to have forgotten my playlist adds by manipulating these files so much. What else is at risk. Will it just re-analyze the most recent adds when I finish trying your suggestion?

Also, all of my main directory is under the same folder so if remove this 5.1 mixes folder under in my main watched directory, I won’t have the edits intact anymore if the move doesn’t work. Sorry for the paranoia.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.