Migrating Server to New Mac mini M2 Core (Restore Failed)

Roon Server Machine

Current Server: Mac mini 2018 Intel i5 8 GB Ram
New Server: Mac mini 2023 M2 16 GB Ram
both Macs have Mac OS X 14.1.2 installed.

Networking Gear & Setup Details

Ubiquiti Edge Router X, Ubiquity 8 port switch, Ubiquity AP Lite, NAS connected via ethernet to the switch

Connected Audio Devices

RPi endpoints

Number of Tracks in Library

64,000

Description of Issue

I am trying install Roon Server on a new Mac mini. My current server has scheduled automatic backups to the NAS (both mini and NAS are connected via ethernet through the switch).

I am following these instructions:

I initiated a new back up to the NAS. The last successful backup confirms it was backed up to the NAS. Both the old and new minis have the latest Roon installation (version 2.0 build 1353). Instead of logging into my account on the new mini, I select the ‘Restore a backup’ option as described in the help article. I have set up the NAS connection on the new mini and I select the latest backup from the old mini (10 backup dates are available). The restore will initiate and fail at 12%. Error message “Restore Failed. Please check your backup folder and try again.” I tried multiple times, different backup dates and the result is the same (fails at 12%).

Other things I tried:

  1. I copied the backup folder from the NAS to a USB drive (APFS) and I tried restoring from USB instead of the NAS. Same failure.
  2. Since I only have one ethernet cable where I currently have the two minis, I tried to restore over wifi and ethernet connection to my LAN. Same failure.
  3. I’m currently trying to create a new backup file directly to a USB drive attached to the current/old server and will update this shortly.

Hi @Michael_Owsianicki,
Thank you for your patience while we worked through the queue. Are you still having issues with your Mac mini core?

Hi @Daniel ,
Correct, I have still not been able to restore any backup on the new Mac mini. As an update to my original post, I created a new backup on the old Mac mini and saved it to the Desktop (instead of forcing a scheduled backup to the NAS drive). The Desktop is sycned with iCloud and thus the back up appeared on the Desktop of the new Mac mini. I tried restoring this back and it failed at 6% progress.

I also tried saving a back up directly to a USB drive on the old Mac, but it was going to take 20+ hours and I stopped it.

@Daniel,
Any further follow up possible? Is the backup/database corrupt? Is there a fix for that? Is there any issue loading an Intel software based backup onto the Apple M2 software based server? Should I setup the new server from fresh, then try to restore? I didn’t try the latter because I wasn’t sure if I could get the old server working again if the new server restore still failed.

Hi, @Michael_Owsianicki Let’s try setting up a fresh server instance. It will allow us to narrow down what is causing the problem. The old server will still be usable as long as you aren’t signed in on the new server.

Hi @Daniel . I set up a fresh server and deauthorized my server on the older machine. New server worked fine and imported my local files and Tidal library. ARC worked. No issues. I created a backup of the new instance to a USB drive. I tried restoring from the latest back up from the old server (located on a NAS) and same result as previously–it failed at 12% with the same error message “Restore Failed. Please check your backup folder and try again.” The new server is build 1357 and the backup I selected was also build 1357.

@Michael_Owsianicki please use the directions found here and send over a set of logs to our File Uploader?

@Michael_Owsianicki also this sounds like there may be some corruption with your backup. Do you have any earlier backups you can try?

@Daniel I uploaded the log files (there were log files under both “Roon” and “RoonServer” folders on my HD. RoonServer had the latest date modified, while the Roon/Logs folder was last updated yesterday, which was around the time I tried the restore).

I previously tried to restore from the earliest backup I had, which also didn’t work.

Thank you for getting back to me and for your continued patience. Can you also send us the backup you’re trying to use? It would help us diagnose the issue. You can use this link https://workdrive.zohoexternal.com/collection/gnhz54df9ddffa33d49a3be8619bd6376a5de/external

hi @daniel. The file was uploaded last night.

@daniel I’ve given up waiting for any solution or further troubleshooting suggestions. I’m curious however if it was concluded that the database was corrupt and how that could be prevented in the future.