Migrating to Mac mini from MacBook Air

(Michael Owsianicki) #1

Core Machine (Operating system/System info/Roon build number)

Mac mini (2018), Mojave 10.14.6, Roon V 1.6 (build 416)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear R6400, ethernet and wifi connected
Local music stored on QNAP NAS, using Tidal integration

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Output to Raspberry Pi with HAT DAC connected over ethernet

Description Of Issue

Roon core build 416 was successfully operating on a (2012?) MacBook Air with wifi connection outputting to RPi with same DAC as noted above. Purchased a Mac mini and attempted to migrate to the new Mac mini.

I backed up the database from the macbook air (had multiple backups available on the NAS), installed Roon on the Mac mini and restored from backup. After the restore finished I was shown the Overview screen with recent album additions added via Tidal (so the Tidal integration seemed to be working).

However, navigating around various screens I started to notice the screens were not refreshing. Here’s what I’m currently experiencing:

  • I can play both songs from my NAS and Tidal
  • the play count does not seem to be updating after playing a track
  • the Overview and Discover screens just show the spinny Roon symbol
  • when I use the magnifying glass to search the auto populate list works, but when I hit enter to search for something I simply get the spinny Roon symbol
  • the browse Tidal page does not refresh
  • I can browse Library>Artists and my library appears, I can drill down to artists, and tracks within my Main Albums, but the Tidal library just shows spinny symbol.
  • top right corner of Roon software shows the spinny 1/4 circle constantly stuck at 0 added tracks of 18.
  • I forced a library refresh and it doesn’t seem to be importing all of my tracks. See screenshot:

    I have over 20k tracks but only 13k seem to import.
  • my track queue shows the history of tracks I have been playing, however, the My Stuff>History page shows spinny symbol and shows 0 plays.

Thanks for your help

(Noris) #2

Hi @Michael_Owsianicki,

How have you restored the database to the Mac Mini? Have you used a Roon-created backup or have you used a 3rd party backup application such as Time Machine to restore the database?

I mention this because Time Machine backups can sometimes cause issues with the database and it is not recommended to restore this way, as noted in our Backup documentation.

1 Like
(Michael Owsianicki) #4

Yes, I restored the database to the Mac mini from a Roon created backup. I started from a fresh install of the Mac OS and did not restore from a time machine back up.

I shut down Roon today, restarted, received a message stating the software was being updated, which lasted about 5 seconds. Overview screen still not displaying.

I also tried signing out of Tidal (it had a spinning wheel on the screen that shows the Tidal, Qobuz, Dropbox sign-in screen), shut down Roon, restarted. Now the Overview and Discover screens refresh. Try signing back into Tidal and receive the spinny circle and Overview and Discover return to blank screens. Something is possibly blocking the Tidal sign-in?

(Dylan Caudill) #5

Hi @Michael_Owsianicki,

When you did this, was the spinning icon in the upper-right still displayed?

If you leave the screen on the Overview or Discover screens for a few minutes do things eventually load?

With TIDAL disconnected does everything import properly, or o you still see it stuck at ~13k?

(Michael Owsianicki) #6

When I sign out of Tidal, the spinning icon in the upper-right disappears as well as on the Tidal sign-in screen. The Overview screen loads. The Discover screen is not loading.

When I restarted Roon (while signed out) earlier today it performed a rescan automatically and the import count went from 13k to 15k. Still missing many. I forced a rescan now while signed out of Tidal and no change.

Any ideas why the play history and play count are not updating after I play songs?

(Dylan Caudill) #7

Hi @Michael_Owsianicki,

Moving forward, I’d like to enable some diagnostics on your account while this is occurring. Before I do this, may I ask that you please do the following and make a note of the time you do each:

  • Reboot your Core machine.
  • Start up Roon and let the spinner go for ~5 minutes.
  • Reboot your Core machine once more.
  • Start up Roon and let the spinner go for another ~5 minutes.

This should allow the team to gain some insight into what you’re experiencing in the report. Once you’ve done this let me know the timestamps and I’ll enable diagnostics on your account. When the diagnostics report is uploaded I’ll send it over to our team for analysis.

(Michael Owsianicki) #8

I assumed I was to run through the steps while logged into Tidal.

8:02 PM reboot, 8:03 start Roon, 8:10 reboot, 8:12 restart, 8:20 closed Roon. (eastern standard time)

observations this time:

  • when I clicked on the spinner (upper right) the Tracks Imported was over 29k and then started to reduce/count down while scanning files.
  • the Discover screen was working, but not the Overview screen.
  • History was showing my played tracks
(Dylan Caudill) #9

Hi @Michael_Owsianicki,

Thanks for the reply! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

While the team is looking into things I was hoping that you could try using the MacBook Air as a Core once more just to verify that things are still working in that configuration.

Also, can you verify how the Core is connected to the network? Is it via Ethernet directly to the router or is it connected to any other networking gear?

(Michael Owsianicki) #10

I reactivated the core on the MacBook Air and all works fine. It’s connected over wifi.

The Mac mini is connected over Ethernet, although it also has wifi enabled. Presumably it prefers the Ethernet connection, but not sure. I’ll test with wifi disabled.

I’m also not against trying a fresh Roon install on the Mac mini (not restored from a backup).

(Dylan Caudill) #11

Hi @Michael_Owsianicki,

Yes, let’s give this a try. Please see the following instructions:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
(Michael Owsianicki) #12

Fresh install seems to be working without any issues. Tidal works fine. Overview, Discover, all the screens work normally.

(Dylan Caudill) unlisted #13
(Dylan Caudill) #14

Hi @Michael_Owsianicki,

Thank you again for your patience while our technical team has been looking into this issue for you.

I spoke with our team today regarding their evaluation of the diagnostics report from your install. Sometimes, errors like the one you saw can be spurious, but unfortunately in this case they are seeing signs of low level corruption in your database.

This type of error is extremely rare for us and not one that we see often. Our database infrastructure is designed specifically to prevent this type of corruption, and we don’t take this class of issue lightly.

We’ve traced a few reports like this in the past to hard drive integrity issues but generally speaking, this means that Roon is reading information from your hard drive that is different from what was originally written, and the database is now unable to load properly.

What’s Next?

If you’ve been making regular backups, my advice would be to try installing an older backup. If the database loads properly, your edits, playlists, tags, etc should be intact, and we can confirm everything is performing properly once it’s been restored.

If you do not have any backups, unfortunately you will need to start with a fresh database.

Again, this class of issue is extremely rare for us and you have our apologies for the trouble here.