Migration from old NUC to new NUC - 'problem loading your database

Core Machine (Operating system/System info/Roon build number)

Core i7 NUC, latest version of ROCK, 250GB SSD

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired gigabit ethernet for all devices, all connecting to the same GB Netgear switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Synology NAS 1819+ for the music library, Devialet 440 for playing via RAAT

Description Of Issue
I had a working Core i5 NUC which was reaching its limitations due to the size of my library (450,000 tracks, 26500 albums). I got a Core i7 Nuc with double the RAM and double the SSD, with the latest version of ROCK installed.
Boot up, connected, restored from backup, logged into my Roon account and then the problems started.

  1. It said it needed to rebuild the database, even though this was a restore from a backup 3 hours ago.
  2. then I 'lost connection to the core and the roon icon just started spinning trying to find the core
  3. closed the app on my laptop and restarted it. It asked me to log in to my Roon account AGAIN and then told me a 1 liner: ‘There was a problem loading your database. Don’t worry, our team is here to help’ with a link to this forum.

Help please?

Tried reconnecting several times. I keep getting the login screen followed by ‘there was a problem loading your database’.

So now I am doing a whole fresh restore from backup to see if that works better than last time…

I end up in the same place.

  • restore from backup 100%
  • restart/reconnect
  • can’t find core
  • select different core
  • find core
  • enter login
    How do I get my music back please?

I just tried reset database
I get error ‘status’ ‘failure’ exitcode: 2


got tired of trying to restore, so I wiped and reset the ROCK and now reimporting the entire library as new which will take a while (26500 albums / 450,000 tracks)

After rescanning my library, I was able to access my music but I had lost all ‘history’, since I listen to my music a lot using the ‘most recently added’ feature and now everything was added in the last 24 hours :slight_smile:
So I took one final stab at restoring my previous backup, but instead of using the most recent one, I picked the next older one. That restored fine and everything is back in its place. Phew!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.