Migration to Rock and restore backup

Out of pure interest, I tried to migrate my music library from a PC to Rock. It worked after updating Rock from version 1.3 to version 1.5. However, there are problems with restoring my database. In doing so, I have definitely adhered to the procedure described here.


All my self-inserted images are available. My self-created Tag’s are only 20% available. My created playlists do not work at all. But the most important thing: I checked every single one of my albums manually, so that it is recognized correctly in the database. 10% of my albums were recognized correctly only by this manual treatment. That was a job of several days. And that is exactly what is not accepted. Rock re-indexes all albums.

My music was previously (on the PC) on the path “E: \ Music”. Now the music is on the internal space of Rock. And obviously the restoration of my library expects the previous path.

What am I doing wrong when restoring? Is a complete restore possible without Rock having to re-index all albums? And if so, how do I do it right?

Did you follow the Storage migration instructions linked at the end?

There are ways to confuse Roon that will make it see your files as new imports, which can cause some of this:

If you didn’t follow those steps, I would restore the backup again and try that.

Also moving this over to #support so we can make sure this is worked out for you. Let us know how it’s going @StereJo!

Hi Mike,

I tried to do it all again. The Status Quo:

Roon Rock is running.

Confirm you’re running the latest version of Roon


Make sure you have a recent backup

Have it

Confirm that current file imports have completed

Yes. Have completed

In Roon’s Settings > Storage, disable all old storage folders that contain the files that are being relocated.

I did. And I also cleaned up the database from all the files. No storage is connected.
Now I made a log-off and restored my backup. Nothing has changed. Rock continues indexing the files.

So I did it all again. But after the log off I resetted Rock completely.

After a restart I recovered my backup from the logon-screen. Then I logged in. In the cofiguration “data spaces” I see the following picture

I deleted the old path to my files and activated the internal storage, where my files are located.

And now the same procedure as every time. Rock begins with indexing all my files.

I give up.

Is there no preview of what one is sending? After reading my post, I see many spelling mistakes. Sorry.

Hi @StereJo ---- Thank you for touching base with us and sharing the observations you made during your troubleshooting of this issue. My apologies for the frustrations here.

Continuing forward, after you “reset” the Roon DB on your core machine and then restored the mentioned backup from the login Window you noted the following:

“I deleted the old path to my files and activated the internal storage, where my files are located.”

When you say you “deleted” the paths was the the watch folder(s) “disabled”, then “removed” via the “3 dot” menu to the left? Or, did you click the “3 dot” menu and using the “edit” screen adjust the path(s) to the watch folders?


First I tried to edit the path, but in Rock there is no folder I can choose. Then I removed the path completely via the 3-dot menue. Is that the point that went wrong? Normaly I have to edit the “old an wrong” path. But what do I have to choose in Rock?

My apologies for the confusion on my end @StereJo :dizzy_face: You are correct that internal storage on ROCK will appear in the storage tab and not be a “selectable” option. Sorry for missing that point in your previous.

Roon can get confused if it is looking at the same content in two places at once. So just to make sure I am conceptualizing the above correctly, after you restored from the backup you “removed” the previous watch folders from the application and enabled the “internal storage” watch folder, correct?


That’s Correct!

Great! Thanks for verifying that information for me @StereJo!

When the restore process has completed, what information does the “cleanup library” window display (Path: settings > library > library maintenance > cleanup library)? A screenshot of this window, after the process has finished would be greatly appreciated!


Hi Eric,

this thread took me too long and I think that it is not effective. I buried the rock experiment. Meanwhile runs a small Zotac computer with windows 10, on which Roon Core is installed. The backup restore was not a problem. Now I have what I wanted: A small, economical and yet powerful Roon server. And absolutely quiet, since he has no fan. Thank you for your help.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.