Migration to ROCK observations

Yesterday I migrated my existing Roon Server to ROCK, running on a NUC 7i5. I really liked most of the set-up experience, which was pretty unproblematic. And the result I am hearing so far makes me happy as well.

Still, I wanted to share one piece of information that I didn’t find called out in the documentation, which cost me quite some time.

As described in the documentation, I started by downloading the factory reset image, flashing it to the USB stick and installing ROCK. If I recall correctly, the version linked in the documentation is based on Roon 1.3, although the current version is 1.4.

Following the instructions, I tried to “Restore a Backup” when connecting to ROCK. My backups are stored on my NAS, so I used to restore dialog to set up the connection. However, when looking for backups in that folder, the Roon Remote was only showing me the “spinning” Roon logo for a long, long time. So after checking the permissions of the files on the NAS, I decided to perform a fresh set-up of ROCK to update to the latest version.

Of course, the the About dialog immediately showed me that a new version of Roon OS is available, which I installed right away. Because I wanted to follow the documented instructions as close as possible, I went to the Web UI afterwards, reset the database and tried to restore my backup again. Still not working.

Again, I tried to setup ROCK as a new instance. And surprise, surprise - there was another update waiting for me. While Roon OS was updated before, now ROCK wanted to update Roon itself. I did that and was afterwards able to finally restore the backup I had made.

Suggestion: Please keep the factory reset image in line with the latest, compatible version of Roon. Alternatively, please fix Roon so that it properly complains that the backups it found cannot be restored with the currently running version.


@support good points made here. Moving this to the ROCK area

Good feedback, thanks @Boris_Pruessmann!

Expecting delivery of a NUC7i5BNH along with the Akasa Newton S7 fanless case next week. How did you find the migration to ROCK in terms of sound quality? Any improvements there?

1 Like

Sorry, changed too many things at the same time (receiver, DAC) to actually judge wether the NUC made any difference regarding sound quality. But then again, I didn’t make that switch because I was expecting better quality but because I wanted multi-channel support…

1 Like

Is this issue resolved? Is the ROCK factory reset image in line with the current Roon build?

yes, it has been

Well, as of May 21, the factory reset image (v1.4) was out of sync with the current version (v1.5) @support. When setting up my NUC ROCK, it was unable to find the backup from my Mac version that I was migrating from.

After reading this post, I skipped the restore backup part of the instructions, logged into my account (from the NUC ROCK), and then updated the ROCK using the web UI. I then reset the database and shut down/restarted the NUC. I had to reinstall the CODECS, but by then, I could see the OS and ROCK versions had been updated to the latest (v1.5). Then I followed the setup instructions (didn’t log in to my account but instead “Restore Backup”) and this time, the backup was found. Now my ROCK is running properly.

1 Like

Thank you RLS for this tip as i wondered why Rock did not do a unattended update after install. This saved my database migration from Mac Mini to an Intel NUC.