Minimal CPU freq for Roon Bridge


I’m running Roon Bridge on a NanoPI with DietPI OS. The NanoPI is connected to an Armature Hecate XMOS208 card, then to my DAC.

I’m wondering if RoonBridge’s RAATServer process does not start properly if it observes, at boot time, that the CPU consumption reaches 100%. So is there a self limitation control when it runs on a low power computer?

Because I’m trying to build a solution with a minimal power consumption, I’d like to reduce the CPU frequency to the minimun possible. Streaming DSD 128 in Dop dormat with Raat must be still possible and in any case the sound quality must be degraded.
So I practiced some tests, thanks to diet-pi configuration/performance tuning parameters, and encounters some weird issues.

First, the NanoPi booted with its 4 CPU cores at 1,2GHz. The CPU governor is set on its default with a range from 240MHz to 1,2Ghz.
Playing a DSD stream in this condition displays at most 3 or 5% of CPU on 1 core for some Roon process. The NanoPI is not stressed at all.
So step by step, I decreased the CPU frequency down to 240Mhz with a CPU governor setting set on “Performance”. The Dietpi never change its CPU freq on demand, no matter it runs always at the minimu 240MHz on Quad cores.
In such condition, playing a DSD file shows a CPU consumption about 15% or 35%, this is what I observed with HTOP command. The fact is that the sound quality was ok and the ssh command still responsives.
The problem appears on a reboot. Once rebooted and the network connectivity restablished (ssh connection possible), the RAATServer process shows a 100% occupation on a CPU core and never start. it is neiher visible from a Roon application.
I had to restablish the CPU frequency up to 600Mhz in order to render the roon bridge up and running and to be able to boot correctly.

Does anyone knows what the RoonBridge (RAATServer process) is doing to block indefinitely at startup time on a low power CPU an if there’s a mean to fix that ?

UPDATE: fixed a mistake on the process name which is RAATServer and not RoonServer.


UPDATE: fixed a mistake on the process name which is RAATServer and not RoonServer.

I used the dietpi htop (from the core login menu) and on a Pi3, the cpu usage is surprisingly low - roonhelper and raatserver each using less than 3% each.

Of course I can’t watch during boot, but most systems don’t overload cpu, they simply take longer to boot :slightly_smiling_face:


The surprising fact is that when you reduce too low (under 600MHz) the CPU frequency, the RAATserver seems locked and unable to start (not visible from the Control app).