Minor issue - Recents timestamp incorrect

I noticed that the timestamp for Recently added music is incorrect. Albums imported only a few mins ago is being displayed as “Added - 1 Days Ago”. Albums imported a few hours ago is correctly displayed as “Added Today”. But then albums added yesterday are also showing up as “Added Today”. Anyone else notice this strange behavior?

Yes that would explain what I’ve noticed. I view album’s “sorted by date added” and noticed a few albums not in the list, I later found them a few screens back for some reason. Ive just now checked the date stamp and they are different even though they were added at the same time. Good to know i wasn’t going crazy :slight_smile:

I am the same way. I create playlist (Focus) based on added date. I definitely thought I was losing my mind.

Can you guys give us the details of your system?

I ask because the import date is going to be based on the date/time settings for the device running your Core.

My core is running on Qnap TVS-471

Server running on custom built i7-3770s pc, Windows Server Essentials R2.

Ok, and you’re both seeing import dates different than the system clock on your Core device?

I ask because if I was in NY with my Core set to a European time zone, for example, I would expect to see this:

Thank you Mike. However, i am not understanding what you are saying. Even if the timezone was set to lets say EST, why would an album I added a few hours ago show up as added today while ones I added minutes ago show up as added 1 day ago. If the time zone was off wouldnt ALL the timestamps be shifted not just a select few? If this was the case, then the issue would be predictable. What I’m seeing appears to not have a pattern. Maybe I am not understanding you correctly?

If my Core’s clock was 6 hours ahead, an album that was actually imported at 5:30pm would be imported “today” (11:30pm).

If I import another album an hour later, it would be imported -1 Day Ago, because the import at 6:30pm my time is going to be communicated to the app as having happened at 12:30am tomorrow.

We can fix the display bug here and assume that “albums imported tomorrow” is the same as today, but I’d rather figure out why your import times are off.

Time zone on the nas is correct and set to local time zone.

Just curious if there has been any progress made on this?

I was just looking at Roon today and two albums I added yesterday are showing up as added today. I did check the time, date, and timezone of Roon server and its correct.

More info: this morning saw that the same two albums are still showing as Added Today. I tried to use the screen refresh feature but that didnt do anything. Only when I restarted Roon did the timestamp change to “Added 1 day ago”, though that in itself is still not accurate.

@Tboooe ---- Thanks for the feedback! Can you do me a favor and confirm that the system time is the same on core and remote machines? Thanks!


My core machine is headless running roonserver so from the command prompt, when I type “time”, “date” and “tzutil /g” the correct values are given. My remote machines (laptop, Android tablet, Android phone) also all show the correct date and time.

@tboooe ---- Thank you very much for the update. It is appreciated :slight_smile: Can you confirm that all of your remote devices (laptop, Android Tablet, and Android Phone) show the same time stamps, or are they showing different time stamps? Let me know as I look forward to your findings, thanks!


Eric, all my remote devices also show the same time and date.

@tboooe — We have been actively trying to reproduce this issue in house to no avail, so your consistent input has been very appreciated. In order to further this investigation we would like to start by gathering logs from one of your remotes. I believe we already have provided you with a support ID from a previous issue and will be following up with momentarily via PM. Thanks!