Missing Album in Roon - What gives?

So I’m happily searching for an album I ripped before I give the CD away to my ageing father to listen to in the car and to my horror, Roon says it’s not there! I immediately interrogate the family to see if they have been messing with Roon and it’s settings. I get resounding denials that anyone has even touched it. So I do some digging and well what do you know, the album is there on my NAS and showed up quite happily before I bought a Nucleus and upgraded to 1.7. Screenshots attached. Any ideas anyone?

Just guessing here, but it looks like your stuff is organised by artist, not album.

Roon has probably put your Connick cuts into their original albums.

Yes, thank you, it’s just on loan to my Dad but normally my CD’s do not leave the house, hence me checking I have a copy just in case it gets ruined, lost, eaten by my Dad’s dog or stolen by evil thieves.

I’ll take your case pro bono if you’re ever sued, Neill. :slight_smile:

Of course, I’m not a lawyer. I just play one on this forum.

1 Like

Thanks, this shouldn’t matter, with an artist search, it will show all Harry Connick, Jr. available to me, whether is it on my NAS, Tidal or Qobus. Which it does, if I ‘Uncheck’ The Only Show My Library Tab.

Ha ha thanks! Luckily for me, I am one!

So just to understand, inside the ‘Connick’ folder you have, what, one album’s worth of tracks, yes? And none of those tracks appear anywhere in Roon, yes?

My next guess is that the rip was in an unsupported format. My next guess after that the tracks have been marked corrupt for some reason.

My next guess after that is that you were inebriated when ripping, and actually nothing made it to a digital format.

I’m afraid John, none of those guesses are correct. The rip was all fine, in Flac and an accurate rip from dBPoweramp. Here’s a screenshot of the MusicBrainz MetaData Tag editor, clearly showing happy files.

Hi Neill

Maybe I am completely wrong, but from your question I get the impression this is the 1st CD that you ripped and added to your collection after starting to use a Nucleus and upgraded to 1.7.

So here a number of questions/suggestions

  1. Have you already added succesfully another ripped CD, stored on your NAS, to your Nucleus with Roon 1.7 ?

  2. Have you already tried to execute a ‘forced rescan’ of your watched folder

  3. Have you checked in Settings-Library-Skipped Files if (some of) the tracks from your CD are shown?

  4. Have you tried to searched for 1 (or more) individual tracks from this CD in Roon?
    If you do find 1, please check file info to check location
    If you find more than 1, please see if you can merge them into 1 album, and check what Roon then shows in ALbum view.
    If you find none, try to convert your audioformat with dbPoweramp from flac to e.g. AIFF, and try to re-import (i.e. copy this CD into the watched folder and forece rescan).

In one of these steps (and hopefully already step 1 or 2) should help you to get the issue solved.

My 3 cents,

I think your Storage settings could be improved. Set the folders to Q-Music Folder\CD Quality Downloads, Q-Music Folder\CD Rips etc. You don’t want to include the server and backups in the media folders. Then try rescanning the library.

Dirk, no, but everything since rips fine onto the NAS and shows up. that’s a great suggestion with your folder structure and I’m trying that now to see if it makes a difference.

Great suggestion, trying this now:

1 Like

Hi @Neill_Strickland,

The advice above to only have music files being watched is definitely a good one.

Also, I’d like to point out some documentation we have that may be helpful here. In our KB we have an article about Skipped Files and an article about why some files might be missing from Roon .

If you go to Settings > Library > Skipped Files do you see any of your missing files there?

If you filter by path on the Tracks browser do you see this album?

Hi Dylan

It’s still not showing up. I looked in skipped files, it’s not there, just some files mostly with ‘…’ in the titles. Do you think having the previous core on the NAS still there nut not logged in could be an issue?

I just duplicated the file, deleted the old one from the NAS and dragged the duplicated file into the the NAS and did a Force Rescan and it showed up. Me thinks there’s a few Roon Issues going on. I’m still having Artwork issues from a previous thread

Ok so it looks like the issue here is the period after Jr. If you remove the period on the folder it reappears in Roon after a Force Rescan

I think I’ve read about using three full stops instead of an ellipsis in file names causing problems.

Yes for sure that does cause problems

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.