Missing Albums after initial Roon install [Resolved]


New Roon user here.

I am running the Roon Core 1.3 (242) on a Late 2012 Mac Mini Server (2.6GHz Core i7, 8GB RAM, SSD). My music files are stored on a Synology NAS device that is mounted as a volume on the Mini. The path to the files in Roon is a local Mac path, since that volume is already mounted.

Roon imported the huge majority of my library (~8000 tracks) just fine, as far as I can tell, but I am missing some albums.

For example, Paul Simon’s “Stranger to Stranger [Deluxe Edition]” is not shown at all, nor is the Chris Thile & Edgar Meyer album “Mandolin & Bass”.

I turned on Show Hidden Albums, which didn’t change anything.

I looked in the Skipped Files list, and one track from the Thile/Meyer album does show up there (track #6) as being in an unsupported format. (I believe that to be an error; it’s a regular ALAC file like the rest of my library.)

I’ve tried forcing a re-scan, which did not change anything.

I read the document here and checked the various things that it suggests. I don’t have special characters in the file path, and they do not show up if I filter my library by path. Here’s a sample path:

/Volumes/music/iTunes\ Music/Paul\ Simon/Stranger\ To\ Stranger\ [Deluxe\ Edition]/02\ Wristband.m4a

What might be wrong?

1 Like


Not showing M4A as a supported format. Roon cannot play DRM locked files, btw.

Thanks for the reply. .m4a is the extension for Apple Lossless (aka ALAC), and also AAC (DRM and not), so that’s not the issue, but thanks for the suggestion.

I solved my problem, and I’m super-embarrassed, but I’ll post the solution here.

I actually had TWO volumes mounted on the computer both called “music”. One was a network share, and one was my old local-attached storage, from before I installed the Synology. I accidentally pointed Roon to the old volume, so it was missing my newest music.

It seems that Roon won’t let you select a mounted share directly on the Mac, which is fine. I have it pointed directly to the NAS now.

Sorry for wasting your time.


@Michael_Kobb Shares should use the native SMB format to the source not a mounted volume reference on the local machine

See https://kb.roonlabs.com/FAQ:_What’s_the_best_way_to_configure_my_NAS_for_Roon%3F

Hi, @wizardofoz, yes, thanks, I maybe wasn’t clear in my follow-up post. I have the Roon Core pointed directly at the NAS via SMB now and all is well. Appreciate the response.