Missing albums and missing tracks

The problem with Roon is that sometimes it misses albums and sometimes it misses even a single track from an album.
Let’s use Mozart 225 as an example. Albums 1 to 19 are OK but albums 20 and 21 are missed, why? All albums are ripped in the same way using iTunes. Sometimes Roon misses just one track from an album.
This is quite annoying as with large colelctions I have to check that all files in the NAS are properly scanned and that they are scanned properly, as a consequence, I am spending hours without much progress!
The fact that iTunes sound is poor and Amarra is even worst that Roon at identifying albums does not make me feel any better!
Can you help?

1 Like

Can you check the files names on the NAS? Roon sometimes has issues picking up albums / tracks with special characters in them.

Are the missing multi-disc albums identified as a separate album? This sometimes happens when the tags and disc numbering are not consistent throughout the set.

Actually I have solved the problem using XLD instead of iTunes for ripping. Cannot understand what was wrong in iTunes ripper but using XLD the problem is solved.
The only reason why I am not using iTunes as a source for Roon is because it loses the NAS address from time to time and this is an iTunes problem that has never been solved.
Honestly, after being in computer audio for 10 years (I was an early adopter), I am seriously thinking about selling my dedicated laptop, my 3 NAS, my Roon and my Amarra with Dirac licences and buy a CD/SACD transport (having a pair of Devialet monos the DAC is in the Devialets).
I am wasting way too much time in getting my collection right rather than listening to music!


and at the end of the day?

At the end of the day I am still trying to get my collection right in the NAS but I will re-connect my Meridien CD transport so I have back up system when I get sick and tired of computer audio.
Anyone who believes that computer audio is easy and straightforward should have a go, mosy (I haven’t tried them all) have still a long way to go before the become bullet proof.
Maybe Roonlabs should develop their own ripper to make our life easier!

1 Like

225 mozart https://www.theguardian.com/music/2017/jan/01/mozart-225-review-cleverly-planned-comprehensive-box-set has truckloads of metadata. The boxset is 200 cd’s …and booklet. Qobuz has them too incl.metadata.

no NAS here but Seagate Backup Plus 5TB Portable External Hard Drive USB 3.0, NUC/rock

I used to have a USB external drive, NAS seems to be cool but it isn’t!
iTunes work fine with attached storage but not with NAS.
NAS can be very quiet and be located away from the audio gear while USB connected storage cannot be placed further than the USB cable allow and they are usually noisy. My NAS is only 6dB of noise.

Intel Nuc and hd as (described by Roon) is silent here.

I have had a number of problems with albums in the watched folder failing to import to Roon. Originally thought this was connected with the ripping approach (mainly using dbPoweramp and occasionally iTunes) or with the file format (FLAC or ALAC).

My ripping setup is on a Mac (Roon Core runs on a Nucleus+, and the media files are on a QNAP NAS). Usually, I look at the NAS storage on SMB, and everything looked fine - including the files that Roon wouldn’t import.

I then logged on to the NAS using AFP, and I found that the problem file folders had a small question mark in a box at the end of the folder name. I deleted that symbol (whatever it means) and forced a rescan - and everything that should have loaded did load.

I’m not sufficiently technical to know what I’ve done here (what is the question mark in a box / why is the filename ‘normal’ in SMB and showing the extra character in the AFP / why does dbPoweramp sometimes produce that result), but it seems to have worked. So, for the moment anyway, a relief…

1 Like

@Andrea_Tubaro @mikeyjfs – if you guys have files or albums that are not importing, we’re happy to take a look.

The best thing to do would be to note the path where the music is stored (a screenshot of the file info in Roon would be best). Then zip up the entire folder, and put that zip file in Dropbox or similar.

Once you have a link (or if you need somewhere to upload to) you can just PM @ivan and myself with the link and the screenshot, and we’ll take a look.

The screenshot is important because sometimes this is related to paths or filenames. Other times it’s related to the media or the file tags, but in any event, we can check this stuff pretty quickly, so feel free to send us examples guys :slight_smile:

1 Like

I spotted some files were not importing, it turned out the folder name had a space at the end of it. I deleted the space and the files loaded.

Delaying the characters that Roon does not like iseems to help (eg: “).
Using XLD instead of iTunes to rip CDs seems to help too.
It is getting better but mastering Roon is not easy.
I will certainly get back to you if I get into more problems. I am still working on Mozart 225 and I will then have to do the old Mozart collection from Philips. Bach cantatas will be the 3rd challenge but I am not in a hurry. The smart Playlists of iTunes remain a good idea but as long as I have to check each album for completeness of the uploaded files, smart Playlists would not make a big difference.
It remains to be understood why sometimes Roon is missing a single aiff file from an album, it may not be random but characters such as “ are not the only explanation.
Thanks for you help anyway!

mike - many thanks for offer of support. However, at this point, it looks like I’ve found the core of the issue and therefore should be able to review and correct in future (time will tell!).

There remains the puzzles of (1) why dbPoweramp (or my subsequent tidying up of folder names) seems to produce the ‘question mark in a square’ at the end of the folder name, and (2) why the symbol shows up when connecting to the NAS through AFP, but not through SMB.

I know this is an old thread but it seem fitting as I have a problem which I can not figure out how to solve, I have ripped 3 CD’s namely John Scott The North Star, Ruby and Time of the Wolf. From the ripping software they go straight to my ROCK music storage, via network, all are tagged correctly and play fine on other software but ROON does not see the albums. So then I tried to drag and drop the files over to ROON via the app on the PC and it just seems to be stuck on track 1/24 etc nothing else is happening. All other rips have worked both ways just these 3 discs at the moment, any help as I have 700 more to rip and don.t look forward to weird issues like this.
For information before ripping I’d just up dated the Roon build software 778.

Update, I was just about to shut everything down so went in via the web page and restarted Roon Server Software, re started Roon on the PC and all the missing albums were there. So problem solved…Well done me!!

1 Like