Missing Albums that Were Previously Present

Hi, Gang,

I have several albums that are not showing up in Room–even though they have in the past. I am NOT new to Roon and have already tried the obvious actions (forced rescan of music folder, checked for skipped files, switching Show Hidden albums to Yes, restarting Roon, restarting computer) and not so obvious (created a new subfolder within existing music folder and moved missing files there) and have done a search within the help forums.

The missing albums are in an artist folder where some of the albums are showing up, but others aren’t. The ones that are not showing up do not have any special characters or qualities that would make Roon skip them.

My setup:

Roon 1.8 (build 795) running on 2018 Mac mini/Catalina.
Music folder lives on an attached SSD drive.

Happy to answer any other questions.

Thanks for the help.


1 Like

Try toggling “Hide duplicates” off to see if that makes a difference.

Sometimes streaming versions just disappear because rights expire or for other unknown reasons, but I can’t think of any reason why local files should disappear.

1 Like

Maybe because they are a version of an album also available from a streaming source where the streamed album version is the primary version and then got lost (expired rights, rights renewal lead to a “new” album object)? Anyone tried if Roon can handle such a situation (make the local version primary or at least unhide it)?

1 Like
  1. Thanks—that was one of the first things I tried (as noted in my OP). No luck.

  2. The missing albums in question are local files—not from a streaming service.

Thanks. Interesting theory. But in the case of the missing albums I’m trying to solve I don’t think I ever selected the streaming version as primary—always my local versions. But the streaming version from Qobuz IS showing in my library and not any of the local versions that are missing from Roon.

So they are not under versions for the one in Qobuz? Try logging out of Qobuz and then see if they show up. Did you do any group alternative versions with these. I have had issues with that sometimes with Roon not finding my local version and only the streaming one. I ended up ungrouping it.

1 Like

Thanks @CrystalGipsy–that worked. As soon as I un-enabled Qobuz, my missing albums magically reappeared. One of the missing (non-streaming) versions was selected as the Primary version, and when I re-enabled Qobuz I was able to confirm that NONE of the Qobuz versions was even in my library…so puzzling, but glad this solved the problem.

Also thanks to @BlackJack for steering this thread down the correct path.

1 Like

Glad that sorted it. Likely the transition to 1.8. I had some very odd database issue with Qobuz and local music after the update that I had to do similar things to fix.

1 Like

Yes… I had an instinct that the albums went missing after the move to 1.8 but wasn’t 100% sure about the exact timeline.

1 Like