Missing All Album Artwork Lately

Last two nights all cover artwork is gone after using Roon for a hour or so, neverhad this before,what might cause this ? Both NAS and Tidal missing.

What remote are you using? in Android try a restart or killing a lot of other apps…this can be caused by lack of graphics ram…used up or not freed up

iPad, I did get a message recently memory was getting full but I removed a ton, wondering if it actually is removed ?

Hi @Rogerdn ---- Thanks for bringing this behavior to our attention. The feedback is appreciated!

Moving forward, to help aide in our understanding of this behavior, may I kindly ask you for the following:

  • Please provide a brief description of your current setup using this link as a guide.

  • Where are exactly are you missing the artwork in Roon?

  • You mentioned that this is occurring on your iPad remote device. Do other Roon remotes exhibit the same behavior?


1 Like

Try clearing cache in Roon settings on the device.

Dylan, I’ll get back to you on this hopefully tonight but since posting I’ve once again lost my NAS connection, I posted on this several days ago, Andrew/SonicTransporter got it restored for me, but it only lasted 24 hrs, Roon has been rock stable forever for me so something has changed, thks for your offer.


I’ll give a try, thks.

Dylan, Roon core is on a SonicTransporter, control is an iPad iOS 11.3.1, Dac is a PS Audio DirectStream with Bridge for LAN, and a microRendu for USB. Roon is 1.4/310. Music is stored on a Synology DS412+. Have about 10000 tracks.

In addition to the missing cover art I now have for the second time in just a day lost my NAS connection. Roon plays normally with Tidal however. The cover art is there initially then sometimes disappears after maybe an hour, both Tidal and my library’s. Library is still available using both MConnectHD and Lumin, i.e., they play normally.

Router is an Apple and network is very stable, I just never have issues running some 16 devices and until a week ago Roon had been trouble free for many months. No connection issues with the other devices, network is wired other than iPad.

I tried last night to reconnect the NAS but was unable, apparently did something wrong.

Edit, just installed 1.5/320.

Hi @Rogerdn — Thanks for the additional info here. This new insight will certainly help!

Can I kindly ask you for the following:

  • Can you please provide a screenshot of your Storage tab in Settings?
  • Are you utilizing any other networking devices aside from the mentioned Apple device?
  • During your troubleshooting, have you tried hosting your Roon Core on a different machine to verify what the experience is like? This would help narrow down the cause of this behavior.


dylan, I removed my drive while trying to restore it but couldn’t figure it out so it currently looks like,

But this is what it was before,

And my network,

No haven’t tried hosting, don’t know how to do.

Btw my cover art, all Tidal of course, was ok last night, perhaps the cache clearing I did fixed it.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.