Missing Files after moving data to NAS

I am running Roon Core on a Mac Mini. I recently moved all my data/music file is to a new Synology DS916 NAS. I shutdown the path to my old drive and restored Library from backup. I then enable the new folders on the NAS as my new watched folders. After scanning I now have only show 1 or 2 files in most albums. The File names have not changed and the files are on the NAS.

I tried forcing a new scan but that did not work. What do I need to do to make Roon see all of my files again?

Hi @scott_sandifer ----- Thank you for the report and my apologies for the troubles here.

I am not sure if you you have taken a look at our knowledge base yet but we have a detailed description on the best procedure for changing storage locations to ensure that all information is preserved within Roon.

You mentioned that you enabled the new folders on the NAS as your new watch folders. Can you confirm if you had created new watch folders in Roon or edited the pathways to your file locations which are now on the NAS?

-Eric

Hi Eric,

Thanks for your reply. Yes I’ve read the knowledge base article. I tried that exact procedure first and it did not work correctly. The library would seem to complete building/scanning and then suddenly, 9/10 of my albums would disappear and it would start adding them back all over again. I thought I had it working yesterday with the restore I did yesterday. All my albums and files showed up and it was not constantly scanning. However, this morning I deleted a single file from my music folder and it triggered Roon to remove almost all my albums again and start scanning/re-adding them. Thats where I am at them moment. Not sure what to do to fix this.

Hey @scott_sandifer – can you confirm the exact steps you followed to move your database over and update your watched folders to the new location? It shouldn’t involve adding new folders, just editing the path.

Let us know the exact steps you’re taking here, so we can understand how your storage is setup and we can get a better sense of what’s going on here.

Also, can you confirm the size of your library in tracks? It sounds like you’re trying to run the Core on the NAS, and while that NAS falls short of our recommendations, for smaller collections it should be ok.

On my first attempt this is what I did…(a few days ago)

  1. Started with Roon core running on a Mac mini with internal drives for everything Core/Music (used about a month) . The Core and watched files were all on one device (one folder). Everything was fine…
  2. Purchased a new Synology DS916+.
  3. I made a backup of the database.
  4. I created a Music share on the new Synology NAS…
    6)Copied all the music files to the shared Music folder on the NAS.
  5. Disabled the watched Music folder in Roon. (watching nothing now)
  6. went back into Roon and removed old watched path pointing to PC and changed it to point to the new NAS music/watched folder.
    9)Roon Scanned all files and would finish. After finishing Roon would immediately purge most of the file and start scanning again…Tracks would go from about 12,000 down to 2,000. Then start all over again. Went on for several days. Complete disaster…

On my second attempt (yesterday)…

  1. Completely removed Roon from the computer using Clean my Mac 3. Left data files on NAS (12,000 files).
  2. Reinstalled Roon core on Mac mini.
    3)Restored Roon database from backup. (backup is from working config when database and files were both on Mini)
  3. Made NAS music folder a watched folder (only watched folder)
    5)Roon rescanned automatically and corrects most file paths.

Issues I have now are that Roon took some songs and created duplicate Albums containing a single file and I’m not sure how to remove without deleting the song…which would also delete it from legitimate album…

The two times I deleted a file, Roon would again purge all but around 2,000 files and re-add everything back. However, this time it luckily does it once and stops…

Playlist no longer work…Some “custom” album art missing (not all)…

Not sure what else is screwed up since it takes a lot of time to check everything…

Hi @scott_sandifer ---- Thank you for follow up with and taking the time to clarify that information for us. Both are very appreciated!

Moving forward, I have a few more data points I’d like to gather from you. Please see below.

  1. When you performed the above, did you use the backup feature or was the DB moved by “hand”?

  2. When you used Clean MY Mac, was the Roon database (in /Library) removed?

  3. How are you adding the new watched folder? Can you please provide us with a screenshot of your “storage” tab please.

Looking forward to your feedback!
-Eric

  1. Backup Feature
    2)Yes… Everything was removed
    3)DIdn’t know there was more than one way to add watched folder? See photo.

Hey @scott_sandifer – maybe I’m not reading this correctly, but it seems like the Core started on the Mac Mini and is still running there. Is that correct?

If that’s correct, you shouldn’t have needed to use the backup and restore feature at all – the instructions here should have been sufficient.

I’m surprised your having the other issues mentioned in this thread, so it would be great if you could just confirm that if you restore from a fresh backup made before this all started, and then follow the instructions I linked above, that you’re still having this problem. Let us know if so, and we’ll take another look.

Thanks!

No, that is correct! The core is still on the Mac mini. I agree, I should not have needed to use a restore but if you reads the other posts I provided, I did follow those instructions… Like I said before!! After following the instructions you reference in your response …They were NOT sufficient in my case…

“9)Roon Scanned all files and would finish. After finishing Roon would immediately purge most of the file and start scanning again…Tracks would go from about 12,000 down to 2,000. Then start all over again. Went on for several days. Complete disaster…”

I gave up after several day of scanning and re-scanning and restored from backup…

“another look”… Nobody at Roon has looked at anything… only asked me questions several ways…

BTW… I think I have figured out what is going on and solved the major issues for the most part…

What was the problem?