Missing files on import (new install)

Core Machine (Operating system/System info/Roon build number)

Windows 10 (1903), Intel Core i5 with 16GB RAM, MSI Mobo, Roon build 571

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ubiquiti Edge Router connected to Ubiquiti and D-Link Gb switches, Wi-Fi is Ubiquiti/AmpliFi HD Gamer’s Edition (although all current connections are over Gb Ethernet)
Synology DS212j NAS with shared music file (added to Roon Folders and actively monitoring)
Dropbox folder (added to Roon and actively monitoring)
Tidal subscription (highest level / MQA) that is active in Roon

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
MacBook Pro (Catalina) connected to Emotiva XDA-1 via USB
Windows 10 Pro (1903) PC connected to Focusrite Scarlett 18i8 via USB using ASIO
Cambridge Audio Azur 851N streamer/Roon endpoint
Gaggle of Sonos One speakers (in stereo pairs) and a Playbar/Sub/Ones “5.1” setup

Description Of Issue
Albums/tracks missing from library.
I have a Synology DS212j running the most current SynOS with “Music” folder/share and Dropbox installed on the Roon Core PC (Win 10 1903) that is seemingly not importing anything from either of those sources. I say seemingly because a lot of the albums that are on the NAS and/or in Dropbox which are also available through Tidal show up in my library but albums that are not available through Tidal do not show up at all. Most, if not all the missing tracks are now duplicated in both NAS and Dropbox (to see if I could get Roon to pick them up) but to no avail. It’s as if Roon is acting as a fancy Tidal interface and that’s all… Obviously, not optimal.

All of these tracks are in .MP3 format (for compatibility) and play on everything I throw them at natively. If I put the .WAV versions on the NAS or Dropbox, the same thing happens (or doesn’t happen.)
While I appreciate the feature of picking the highest quality version available to play, some of my library contains projects that I worked on (I’m a recording engineer/producer) that are either too new, too obscure or unlicensed to be published to Tidal. But of course that doesn’t mean I don’t want to see them. If there’s little to no metadata in the files, will that stop Roon from picking them up even though the file is compatible?

I should also mention that all connections seem in working order in Roon’s Setup and ‘Force Rescan’ does nothing to address the issue. ‘Skipped Files’ is an empty list.

Here’s a Dropbox link to an example that does not show up in the library at all because it exists only on the NAS and in Dropbox folder: https://www.dropbox.com/s/ftg7ehtp9jyn91x/02%20-%20Thanks%20For%20Asking%20(Don’t%20Ask%20Mix).mp3?dl=0

For edification, here’s a URL to the folder in Dropbox that contains the above file: https://www.dropbox.com/sh/z37noaolj1vc9ef/AAD1xj9gsj6Fzi24L81oApaua?dl=0

I picked this folder specifically because the spelling contains a special character that’s not listed in the support info as being invalid but I figured I’d send it to you to see if that’s an issue. That said, ALL folders that do not have companions in Tidal are indeed missing in Roon, regardless of spelling/etc.

Please help - what am I missing?
I’ve been through all the settings, done searches in the community and can find no reason for the lack of sync. between Roon and my local sources. I don’t really need Roon to be only a Tidal intermediary, I need Roon to do what Roon is known for…

Thanks in advance for any/all assistance!
Cheers,
C

Hi @Chuck_Hawks,

Can you share a screenshot of Settings > Storage so we can see how these folders are added in Roon?

Hi @dylan,
Thanks for the response. Here’s a shot of the requested settings page as well as a shot of the Synology NAS’s ‘Music’ share, which has 125 artist folders in it (multiple album folders under most of these) which Roon seems to be ignoring. The security on the Music share allows anyone on the local network to read-access it so it shouldn’t be a privilege issue (forgot to mention that in previous post.)

In the interim, I added a folder on the Roon Core PC’s local drive and added content which was picked up without issue. That can be seen in the screenshot that shows recently added files. I’ve ordered a 6TB drive to install in the Roon Core if that is my only option but that is really meant to contain large lossless format files and I’d still like to keep the Synology share active for areas that are using Sonos endpoints where sound quality is not top priority (.MP3s will work just fine and use much less LAN bandwidth.)
I’ll also mention that the Roon Core PC has had a significant upgrade in the past couple of days. Performance was a little laggy in Windows, so I swapped the mobo and CPU out for a AS-Rock x370 Taichi and AMD Ryzen 3700X, and it’s now got 64GB of DDR4 RAM. Plenty of HP for this application, no doubt!

OK, now I’m probably just going into way too much unrelated detail to shoot this one issue; sorry.
Any help is appreciated.


Cheers,
C

@dylan - UPDATE
I reinstalled the Media Server app on the Synology Diskstation and added the Diskstation/Music share again in Roon Core settings and low and behold, it started importing! I am not sure why this didnt’ work the first time around but it seems to be grabbing files now. The Syn box is running the most current version of DSM but maybe somewhere along the line Media Server app and DSM disagreed with one another and it stopped honoring requests… Who knows. I’m just glad it wasn’t a Roon issue and was relatively simply solved after some head scratching and dart throwing.

Thanks for the quick attention to my issue!
Now I’m off to determine how to get Roon to decode and deliver MQA files in the highest res to devices that don’t decode MQA (851N), and figure out why our new Cambridge Audio 851N is limiting everything from Roon to 96K regardless of the source being at a higher sampling rate… more head scratching. :wink:

Cheers,
C

@dylan (or anyone who wants to chime in) - I’m back… With another related question. Just found in some of the Roon docs that the Core will only do the first MQA unfold and leaves any remaining decode/unfold to the end point… Is that true across the board, even when ‘no MQA support’ is selected for the endpoint in the device’s setup in Roon? As an example, the Cambridge 851N has no MQA decoding capability at all… so that means no matter what I do, I’m limited to 24/96 playing back MQA files even when they’re natively 24/192? Is there no way out of that situation and/or no way to get Roon to do subsequent unfold?

That’s a pretty limiting situation (not saying it’s all on Roon, just that it’s limiting and leaves quality on the table) and has me wondering if this configuration of equipment is not necessarily the right solution for our needs.

I thought about going with the NAD C658 or M10 instead of the CA 851N but it seems research reveals that NAD has a host of nasty problems not the least of which is decoding MQA, esp. if using the DIRAC feature simultaneously.

I’m just trying to figure out how to get the most consistent, predictable solution where all components play well together without going bankrupt - seemingly a much bigger challenge in today’s landscape than anticipated. It appears that everything is such a large compromise that there’s no way to get all components to use their optimal strategy together resulting in the penultimate of what’s supposed to be holistically available.

Thanks in advance for any/all insight.
C

I set my Roon core to always do the MQA decoding. My two MQA DAC’s (headphone listening) are set as rendering only. My main listening setup is non-MQA (no MQA support). I think with this setup, I am always getting the best possible output regardless, and it always shows as lossless in Roon, if that makes any difference.

HI @Chuck_Hawks,

It is not possible for Roon to do more than the first unfold — An MQA DAC is required to do both decoding and rendering. You can learn more about the specific options available in Roon, and what they do, here.