Missing first few milliseconds of track

Core Machine (Operating system/System info/Roon build number)

ROCK on NUC5. Version 1.7 build 500

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Both NUC and D440 plugged with Ethernet to modem cable router (Arris TG3442)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

D440 using RAAT

Description Of Issue

Missing first few milliseconds when track start playing - noticeable on tracks with direct start / no prior silence, for example the Presto of below recording (Qobuz streaming):

How to reproduce: go back and forth between tracks n-1/n/n+1 using next and previous track button. You can hear Presto is missing few first milliseconds. Now if I pause the track, rewind it to start and play again, it start from beginning all good no missing samples.

Trying the same on my Sonos Move over WiFI, I don’t face the issue (Qobuz ruled out). Using D440 with AIR versus RAAT I don’t face the issue now there is an observation: with AIR there is some silence padding between tracks, maybe a second or so. Clearly noticeable comparing with playing on D440/RAAT or Sonos.

I thus made the following experiment: adding 1s silence padding for D440/RAAT setup (via Roon config). I noted this was normally to cope with “format change” which is not my case. This padding feature seems NOT to work going back and forth between tracks using previous/next button (that is a bug) and/so I faced the original issue of missing start. Interestingly if I pause a track and rewind then play (use case without issue) the 1s silence padding is working.

Bottom line I see 2 bugs: silence padding not working using previous/next button, and few first milliseconds of audio missing with D440/RAAT (I have no other RAAT device to try if it is Devialet-dependent). Silence padding could have been a workaround, but it doesn’t work…

PS: no idea if there is a link to version 1.7, it could have been there before

1 Like

Hello @Patrick_LP,

Thank you for the detailed report. I’ve scheduled testing with the QA team for further investigation.

Would you mind linking the Qobuz album you were using in the example you gave?

-John

First note of Presto should start smooth, when first milliseconds dropped you get straight in the note with “t” effect at start.

As I see build 505 is out and correcting some buffering stuff I will try with it and report here if issue still reproduceable (as soon as I see 505 on App Store)

@john issue is still there with build 505, and actually got worse: There are even more samples missing at beginning of a track. With album referenced above, the first note of the Presto is now almost missing entirely.

Hello @Patrick_LP,

Are you noticing this behavior with 16/44.1kHz CD quality tracks, or does it occur only with high resolution tracks?

-John

Im missing the first few milliseconds of track as well this happened most recently on 24 192 Flac files and DSD64. This doesn’t happen on every track and seems to happen when I skip tracks or start playback from fresh.

I run Roon Core on Synology 718+
My endpoint is a Chromecast Audio

@john -

Finally, more people are noticing this.

BTW - I’ve been working on an extensive reply to your last post to me about this.

@Patrick_LP, @John_A_Leighton -

Looking at the scrub bar when this happens, I lose anywhere from 1-3 seconds.
Started happening with V1.7.

If you set your Qobuz sampling to CD quality only (regardless of the source res), does it still happen?
image

When it happens I lose about 100-250ms on local files

Do you have Qobuz?

If you do, does it happen with Qobuz streamed tracks?

This happens to me with a Mac endpoint connected to a preamp via HDMI. However, only on playback initiation, not between tracks. In my case, I fixed it by having Roon preroll silence for 5 seconds (5,000 milliseconds) whenever the track digital format changes.

We may not be talking about the same issue, though, because I think mine may have to do with HDMI sync.

1 Like

Thanks Kuryan

I will try that

Hello @John_A_Leighton,

This is expected behavior. The Chromecast Audio has a soft muting feature that ramps up the digital volume when a new audio stream is started.

-John

Has this been solved? I too have the issue. Very annoying. When you skip to the next track. If you pause the track that just started (but missed the beginning), go the beginning of the track often then it does start from the start.

I have tried all options on ms delay and so on. Nothing seems to be able to solve the issue.

Devialet 220 pro

Issue is still there - I tried again today and got same behavior

Hi it does the same on my MacBook

All fixed reinstalled Roon server and reset chromecast. Time for a Rock

I was going to write a new bug report til I found this. Basically I have this same issue but not just for Qobuz, it also happens with Tidal and local files playing from my PC which is also the core. Roon Version 1.7 (build 610) stable (64bit) running on Windows 10 if that helps.

So yeah, whenever I click the “previous” button to start a song over, once that song ends and Roon continues to play the next song there will be a gap or skip in between the tracks that isn’t normally there. But if I click somewhere on the waveform/playhead bar to make it play from a different spot in the song then let it finish playing, it will transition into the next song correctly with no gap or skip.

And I know what you’re thinking “why not just click on the playhead bar at the beginning of the song instead of clicking previous?” Well that’s what I resort to usually but then you might as well just take the previous button away because sometimes I forget and click previous anyway and then the gap bug happens and I cry for the rest of the night because my immersion was ruined :cry:

Maybe that’s a bit of an exaggeration but I do hope this bug can be fixed soon. Let me know if there’s any other info that would help.

I checked again following new post above, and I am actually no longer facing the issue I originally raised. Could be fixed in version 1.7 (now didn’t see in release notes anything related) or could be due to changing my modem/switch - my previous one was causing some network trouble I could not exactly nail down nor relate to that issue either. If you experience issue still with version 1.7 I would tend to say my network switch was (part of) root cause. Maybe in combination with my Devialet Expert also suspected to misbehave on its network management… It smells some buffer handling issue…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.