Missing Tidal artwork on Roon remote

Hello, I need your help with this.

Core Machine 1 - PC
Windows 10 Pro 64 bit (10.0, 18362);
Roon Core 1.7 (571)

Core Machine 2 - Laptop
Windows 10 home 64bit (10.0, 19041)
Roon Core 1.7 (571)

Audio Devices
Allo Usbridge
Audioquest DragonFly Red.

Netowrking
Router Mitrastar GPT-2741GNAC (Only working as router - Currently WiFi is off)
AP Dlink Dir-825

Roon remote devices
Samsung Galaxy S9 - andorid 10.
Ipad Air 2 - IOs 13.5.1

Description Of Issue
Sometime in may, I lost Tidal artwork only in the remote devices.

I use roon most of the time to enjoy Tidal. Everything was OK until last may when suddenly Tidal artwork disappeared from my roon remote devices. Although, Tidal Artwork on Core Machines still works well.

I have tried all the following without success:

  • Clear cache (roon Cores and remotes).
  • Tried increasing and decreasing memory for artworks (Cores and remotes)
  • Reinstall Roon remote in remmote devices.
  • Connecting Roon Core 2 via Ethernet.
  • Checked Windows Defender and firewall excepctions. Also I tried turning Windows defender off.
  • Disabled my DLink AP and turned Wifi on in my router.
  • Reinstall Roon Core (Both Machines).
  • Reinsatll Windows O.S on Core machine 2 (It was scheduled at all) and install Roon Core.
  • I Have configured Roon Backups on Core Machine 1 into a route on my Wondows D partition.

Nothing works.

Something to take into account is that Tidal by itself does not have problem on my Smarphone and my Ipad.

Another 2 important points:

  1. From my Roon remote, when I select a Tidal album to be added on library, sudennly Artwork for that album appears.

  1. When I Configure my Smartphone (roon remote) as a 4G internet hotspot for my Laptop (roon core) - Obiously I dont have conection to AlloUsbridge - All Tidal artwork is OK.

Regards,
Fernando C.

Hi @Fernando_Chilet,

Are you by any chance running Logitech G Hub software? Please see:

Hello @noris, Thank you for the reply.

Well, I only have a Loguitech webcam on my Roon Core #1. I tried disconnecting and deleting any driver, but problem remains. Moreover, My Roon Core #2 has not had any device attached since I reinstalled windows and the problem also happens.

Hi @Fernando_Chilet,

Thanks for checking the firewall aspect.

When you have one of these Core in “Client Mode” and connect to the other Core, do you also see the issue on the Windows PCs? You can set it up to Client mode by first making a Backup (just as a precaution) and then going to Roon Settings -> Disconnect and selecting the other Core.

Hi @noris,

I just followed your indications (Backups included). First, I left mi Windows PC Core Machine 1 as Roon Core and my Laptop WIndows as a Roon Client. My Second case was with both roles interchanged.

In Both cases, Tidal artwork was OK in Core and Client windows.

Hi @Fernando_Chilet,

Thanks for running this test! Just to confirm here - when you ran these tests, were the Cores plugged in via Ethernet? Since the issue affected two remotes on WiFi, I am wondering if WiFi is an aspect we should consider testing for.

Hello @Noris,

The tests I made between my two Windows machines were over WiFi. In addition, I leave you my home networking involved in this case.

1 Like

Hi @Fernando_Chilet,

Thank you for sharing that network diagram, it is indeed helpful!
As for the issue, I propose the following test:

  1. Can you please set up a fresh database on your Core Machine 2 (the one on the same AP as the phones)? You can do so by using these instructions:
  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  1. Can you connect the iOS/Android device to the new Core, login to TIDAL and verify if the issue is the same?

Hello @noris,

I followed your instructions to the letter but I still have the problem in both remotes

Hi @Fernando_Chilet,

Thank you for running that fresh database test. I would next like to take a look at the diagnostics from your Roon Remote, but before I enable diagnostics mode for it, can I please ask that you reproduce the issue and note the exact local time + date you observe it and which Roon Remote you are using at the time?

Hi @Noris,

If I understand well, I have to take date and time parameters when reproducing the issue. So that, The informaction is next:

  1. I started Roon core Application on July 29th at 19:45:00 (Perú time zone - GMT-5). This was on Machine 2 (Laptop Wndows).
  2. Aproximately 30 seconds after (19:45:30), I started Roon remote on Samsung Galaxy S9.
  3. As It was expected the issue is always present. So 1 minute after (19:46:30), I Closed both Core and remote Applications.

I have the Core’s log of this test. Let me know if it is needed (How can I send you)?

Hi @Fernando_Chilet,

Thank you for running that test!

Yes, if you have the logs, please do send them over, I will send you the details via private message.

Hi @noris,

Log has been uploaded.

Hi @Fernando_Chilet,

Thank you for your patience while we had a chance to review logs.

Unfortunately, there are no issues visible in the logs you sent, the requests appear to be working as expected on the Core level.

As a follow-up, I’ve activated diagnostics mode for your Samsung Galaxy, can you please open the Roon app on it, use it for a few minutes and let me know? I can then check to see if the report has been delivered.

Thanks!

Hello @noris,

Thank you for the update.

On August 14th at 19:12 (Lima - Perú time) I tried this:

19:12 I started Roon core and inmidiatly after, I started roon remote on samsung galaxy.
Then, I was surfing and listening some tracks form Tidal.
19:20 I closed roon remote.
19:21 I started roon remote again.
19:22 I closed roon remote and core.

I hope It can help the analysis.

1 Like

Hi @Fernando_Chilet,

Thanks for your patience while I had a chance to review logs. I am seeing an issue where Roon is failing to fetch the data from our servers:

08/09 20:16:06 Error: Failed to fetch image data: The operation has timed out. (https://imagecache.roonlabs.net/im/1/albums/a600313338393338373135/cover/256sq.jpg)

I’m asking the QA team as to what can cause this on your Galaxy / iPad but not on your Windows Core. Do you have any VPNs active on the mobile remotes that the Core does not have perhaps? Or any proxies?

Hello @noris,
No, I do not have any VPN on my roon remotes.

Please, tell me any update from the QA team.

Thank you,

Hi @Fernando_Chilet,

I spoke to the QA team regarding your case and they agree that this issue appears to be due to the current network setup on your end.

Are you doing anything special on the router? Do you have traffic prioritization on or something like that where the packets to the remotes can be rate limited?

How are your DNS servers configured? On the router, are you using Cloudflare DNS, Quad9 or Google DNS?

Hello @noris,

Yesterday, I could try my Laptop and my Samusng galaxy in my mothers house. I was suprised by the fact that artwork was working OK. So as you said, Problem seems to be caused by my router configuration or my ISP.

To go ahead, I answer the questions:

No. I did not do any special configuration but, maybe my ISP did (Everything worked OK before May).

As far as I see, there is no rate limits on my router’s configuration. The only priorization I can see is:

image

I have tried Google DNS, OpenDNS and then I went back to my ISP’s DNS.

image

What else can I check?

Hi @Fernando_Chilet,

Why do you have multiple VLANs set up? I think this might be the issue, if you are not using the VLANs, I would try to disable them.