Missing tracks after import

Hi!

I have a problem with roon. After importing an album there are missing songs…
2 Brothers on the 4th Floor - 2 (1996) is missing song 2 to 5. The albums are tagged in Picard.
I know, its not an great album mayby, but i like it :wink:

I have tried to
Rescan the album several times.
Restarted Roon
Restarted Roon server
Play the files in VLC amd MPC = no problem!
Checked if there are any duplicated albums.
Check if they are skipped in settings, they are not.

Am i missing something??

1 Like

Have you tried searching for track 01-04? Look if search is able to find it and if the other 3 missing tracks are also there.

Yepp, they do not exist in Roon.

Settings==>Library==>Skipped Files?

Also, I couldn’t make out from your screen shot if ‘Come Take My Hand’ was a missing file, but if it is then the presence of the [ might be a problem. I’ve found in the past that some characters in song titles effect not only that particular track, but sometimes tracks that follow.

If the screenshot is from the actual watched folder and the files are actually in there (not just links) and they are not somewhere else (another album or duplicate in Roon), then they should show up in skipped files. You might want to recheck everything.

Yes, i checked: Settings==>Library==>Skipped Files, and they are not there.
I have Picard to change unsuported names to supported filenames
Heres a pic on the files on my HD:


As you can se track 2 to 5 dont have any strange filenaming.

Well i have rechecked skipped files several times and re-scanned the folder and searched for duplicates.

And a search for One Day doesn’t find anything?

Try to re-identify the album then and pay attention to the shown track listing. Maybe just a wrong identification?

I have tried to search for the missing songs in Roon but they arent there.
As for re-idetify the album, it doesnt work, the missing files arent there when i try to identify the album.

With Settings|General>Show hidden tracks and albums set to Yes?

Strange. I tried to move the folder on my HD to another un-watched folder. Then i hide the album in Roon.
Then i added the album again. Roon rescanned it, Now only track nr: 1 is missing!

Is this an bug in Roon?

Yes it is :slight_smile:

Correct steps:

  1. Move to un-watched folder
  2. Go to Settings|Library and click on Clean Up Library
  3. Check the first option Clean up X deleted files (and the others if needed and you wish so) and hit Clean Up Library
  4. Move the folder back to your watched folder

Maybe? You haven’t shared any details about your Roon setup so it’s hard to tell.

Hello @D-P-West, I can help!

It would be beneficial to know more about your setup, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

In addition to that, I’d like to grab a copy of the album you’re noticing this on, I’ll send you a message momentarily with a link.

Yes of course! HEres my setup:

Core Machine (Operating system/System info/Roon build number)
Windows 10, Roon Server 1.7 (build 528) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Unufi wired network. The Roon server is wired directly to my Unifi Router.
Router is an Ubiquiti USG.
Firewall on machine with Roon server is disabled.
The files are tagged in Picard.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Onboard simple audiocard.

Hello @D-P-West,

I have successfully uploaded all 14 tracks on that album into Roon on my end, everything seems to be in working order for me. Let’s try a fresh import of the tracks and see if you have a different result:

    1. Make a copy of this album outside of your watched folder
  1. Delete this album in Roon (note — this deletes the files, so make sure you have the copy mentioned in step 1)
  2. Move the copy you made in step 1 back to the watched folder for Roon
2 Likes

Thank you @nuwriy i will try you solution.