Mobile app not working with latest build

With the latest build (880) my mobile (android) app is in a loop. It says “software update needed”. Then below that it says “you have the latest version installed”. I tried uninstalling the app and reinstalling, I tried restarting the phone, but I can’t get past “software update needed”. There are no other options available except “go back” which exits the app.

Hi, @Marc_Erdrich, thank you for your post. Could you, please, post a screenshot of what you are seeing on your mobile device when you open Roon?



1 Like

I am also gettin the same issue, both android devices my samsung phone and Fire HD 11th gen tablet both stating:
Software update needed

Roon is trying to connect, but it looks like one or more devices on you network need software update.

Remote Coor
(Roon-007) - 1.8 (build 880) stable
You have the lates version installed

This Phone 1.8 (build 831) stable check for update

I uninstalled and reinstalled on both androids but still will not connect, win 10 machine works fine

I had this but was able to click on update at play store which opens the store app with an update button. Clicking that updated phone app and all good. I have a Samsung note 10+.

Update, I also now see the update, perhapse I rushed the play store update before it was ready
seems to work now… :slight_smile:


possibly the update feature on play store hasn’t made it over to the UK yet as I only have open and uninstall… Will try again in a while.

It appears everyone was right on target here. I went back to play store and the update was available. All is right with the world once again. Lesson learned: patience, patience, patience.

Seriously. This sucks. Been without music for several hours now.

How is it ok that you can update the core and then be unable to listen to anything because your main controller (Android phone) can’t get the update from the Play store? Surely there should be some sort of checking routine or at least a warning NOT to update the core until you’ve confirmed that the Roon Remote update is available in your location (Sydney in my case)?

Patience is ok, but for how long?
I wasn’t desperate enough for the new release to forgo hours of evening listening just to get it!

I totally love Roon, but now I’m understanding some of the frustration expressed in the forum during update times.

Hah hah!
With no music to listen to and time on my hands, I just got around to reading the email from Roon about the latest update.

Last sentence: “Please don’t forget to update your iOS and Android devices before accepting the update on your Core.”

I think I’ve just learnt another lesson about patience.

(Still, to be fair, the warning would have been much better at point of update, not in a marketing email!)

So as my samsung phone and iOS are updated and fine, I still am getting the 1.8 (build 831) for my Fire HD 10, which the 11th gen makes a great controler when it works, any idea as to when the push to the Amazon App store or Google Play will happen…

The funny thing is if I look at the Additional information it is showing the current version is 1.8 (build 880) stable, yet it gives me no way to upgrade
I have uninstalled, reinstalled rebooted and tried again

BTW this is a Fire HD Plus (11th Gen) running Fire OS

1.8 (build831) work fine :slight_smile:

So as I dig deeper, it seems that I can only install it from the Amazon App store which seems to have the old version 831, when I go directly to the Google play store, it says installed, and the only devices it shows are my Samsung, and a HP Tablet but does not show the Fire HD 10 ???

Love the work put in so far…


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.