MOCK: There was an error checking for an update

Roon Core Machine

asRock DeskMini 310, Pentium 5600

Networking Gear & Setup Details

Netgear GS108

Connected Audio Devices


Number of Tracks in Library


Description of Issue

My Roon Core (MOCK) does not update anymore. I get the following error message:

How can I get the Core to update?
Thanks for any help

Firstly, have you got a recent backup?

If you have I’d navigate to the Mock’s IP address and hit reinstall at the top. This should reinstall to the latest and clear this error. Has worked for me.

Thanks @Menzies
I tried to reinstall, but I got an error message that the installation files could not be downloaded.
Replacing the DNS server with (Google’s) then did the trick. The MOCK updated as expected.

1 Like

Just an FYI, my DNS is and and have no issues. So you don’t need to stick with Google of you don’t want to. Glad you got it sorted.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.