Mono Alsa output but Roon ignores this

Hi @support I have a HifiBerry Amp2 using dietpi feeding a single speaker. I have Alsa configured to output both input stereo channels to output to left output channel only in asound.conf as the speaker is connected to the left channel only. This works for everything except Roon which seems to ignore the Alsa config.

MPD and and Raspotify all work and output mono. I know I can use DSP to mix it down to mono but I don’t really like the reduced dynamics DSP causes as I have to have a very low headroom to avoid clipping. It sounds much better using the Alsa mod when I use MPD.

Any ideas as to why Roon bypasses the Alsa config? Is there away round this!

Hello @CrystalGipsy,

I saw your post and brought it up with the dev team. Alsa config is not something that Roon will support because it can cause issues if the wrong settings are applied and Signal Path/syncing would become inaccurate.

This is not a bug, but is designed to operate this way. I would suggest you use Roon’s DSP engine to mix to mono, and optionally add some gain to the DSP to keep the DSP dynamics intact.


Thanks Noris thought it would be by design and makes sense. I’ll just stick with DSP then.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.