Most played data suddenly changed

Roon Core Machine

2017 MacBook Air running MacOS Mojave
1.8 GHz Intel Core i5
8 GB 1600 MHz DDR3
Music resides on a 5Tb Western Digital external drive connected directly to the MacBook Air.

Networking Gear & Setup Details

Verizon FIOS router, connected via ethernet

Connected Audio Devices

95% of listening is via a Schiit Bifrost 2, connected directly to the MacBook Air via USB
I also occasionally stream Roon to my iPhone

Number of Tracks in Library

119,255 tracks

Description of Issue

Without getting into the “why” (long story) I recently made the following changes to my setup:

1.Disconnected external drive from the MacBook Air and connected to my main desktop computer on the network. Reconnected it to Roon via network share. Waited out the re-scanning, etc.

  1. After a few days, it was clear that I had created performance issues by doing this, mainly in that it was now taking Roon 10-15 minutes to recognize new songs added to the external drive.

  2. Decided to go back to the original configuration. Moved the drive back to a direct connection with the core. Reconfigured storage settings in Roon. Waited out the rescanning, etc. one more time.

When all was said and done, everything was back to the way it was in the beginning, except for one thing, which for me is pretty important: my data re: “most played” seems to have been wrecked.

Here’s a screenshot with an example. This is a bookmarked view that I use a lot. It shows albums added in 2022, ranked by most played:

Note the album circled in pink. That album is far and away my most listened to in 2022. It appropriately showed up first on this page, until I started all the changes described above. Also, there are several albums on the screenshot that are ranked as “more played” than the pink-circled album … and these are albums I haven’t even listened to once, yet.

So, my questions: 1) what happened?, and 2) what do I need to do to get my “most played” data accurate again?

One last note: I thought restoring from a backup would be the simplest solution, but for some reason, Roon reports that it is unable to restore any of my backups, saying “Restore failed. Please check your backup folder and try again.”

Thanks in advance for the help.


Let’s start with the backup question. What version of Roon are you using now (build 918 is current), when was your last backup, and do you know what version was used on your last backup? Versions prior to 880 we at risk of data corruption for the backups, which were corrected with that version. Also, 914 and then 918 addressed some issues with the Mac core and client application.

Hi Robert –

I’m on 918. My last three backups (3/26, 3/22, 3/18) are all 918 as well. There are three build 913 backups prior to that.


Also, I don’t know if this is related, but I was just looking at my history, about a third of which looks like this:

Note how many of the songs are said to be “unavailable.” In fact, these songs are available as always, but here’s the weird thing: if I click the album link in one of the “unavailable” listings, Roon reports: “This album was not found.” However, if I click the artist link in the “unavailable” listing, I can get to the album that way, and nothing seems any different from the way things have always worked.

But why does Roon, on the History page, seem to think certain albums are missing, even when they aren’t, based on the way I try to navigate to them? Could this be affecting the “most played” issue I’m having?


Brock, when you restored from a backup, was it from one of the 918 backups?

Next question, where I’m over my skis, are the “Unavailable” albums from the screenshot local files in your library or from Tidal or Qobuz? I don’t subscribe to either service, all my files are local so this is where I start to fall down with ideas. Have you forced a rescan of your library to see if that helps with the “missing” files?

I’m wondering if Roon is viewing the change in file location from the external direct-attached Air drive to the main PC and back to the Air may have caused Roon to lose continuity of the library, and therefore it thinks this may be new set of files.

Hi Robert. I haven’t restored from a backup. Roon won’t let me, as noted above.

The unavailable files are all local files.

I’ll try the forced re-scan. Thanks for your help.

The forced rescan didn’t fix it. Also, I had to restart Roon right after taking the history screenshot above. Since I did that about 12 hours ago, my Roon history has looked like this:

What the heck is going on?

I am tagging @support to assist.

Thank you @Robert_F.

@support, are you here? I’d like to get this sorted, especially the non-functioning backups part. Thank you.

Can someone please help me? @support used to resolve stuff via this forum in a matter of hours. It’s been almost five days since I posted my issue … should I be trying to get @support some other way?

1 Like

Hi @Brock_Bair ,

I suspect that something went wrong when you tried to migrate the files from one storage location to another:

It would be best to focus on why the backup is not being restored properly, can you provide some more details on where the backup is being hosted, is it on a network share?

Is it possible for you to copy the backup to a USB and connect that directly to the Core and try to restore it once more? Let us know if this helps!

Hi @noris. Thanks for the info. My Roon backups are on a drive attached directly to the core. So, unfortunately, it isn’t a network share issue.

Other ideas?


I’m really disappointed that nobody in @support at Roon has really even tried to help me. It’s been over a week since I started this thread! @brian who can help me?

Hey @Brock_Bair,

So sorry for the delay in getting back to you :see_no_evil:

Could you please copy one of your latest backup on your MacBook Air. Once there, could you please try restoring it again?

Many thanks :pray:

Actually, enough time has passed that it no longer makes sense to restore, as that would discard all the usage stats that have been compiling since I first posted 8 days ago. Since the whole point was to restore accurate usage stats – then, that day – it makes no sense now to throw away what I have to accept as my up-to-date and “accurate” stats.

Sorry @support, you totally dropped the ball on this one. Now I just have to accept that my Roon data will forevermore be inaccurate. This changes my opinion of you, frankly, and I’ve been a fanboy customer for 5+ years. Thanks a lot for that.

And no, your backups still don’t work, regardless.

Hey @Brock_Bair,

I appreciate you following up with this post to explain in what ways what we have done could have been done better. We want to hear this and we’re grateful for your kindness.

We are truly sorry about the experience you’ve had when wanting to restore your data… we didn’t intend and sure wish this wasn’t the case. We are dismayed we’ve disappointed — we’re learning and striving to get to even better results.

We want to thank you for sticking with us for so many years, despite things that could have been done differently. Better.

@beka, are you seriously asking me this question? It’s pretty self apparent what @support could have done differently. Let’s start with this: SOMETHING. You could have done something. Instead, you did nothing.

At the very beginning – 10 days ago – I laid out a number of issues:

  • Corrupt “most played” data
  • Inability to restore from backup
  • Existing tracks being reported as missing in my history

Are any of these issues solved? No. Have I received even a useful suggestion on any of them? No.

So, what would I have you do differently? I’ll repeat myself. I’d have you do something. The fact that you did nothing tells me everything I need to know about Roon right now. The fact that you would have the gall to ask me such a question (and in a somewhat challenging tone, no less) is, frankly, appalling.

@brian, what has happened to the Roon I used to love and respect so much?

@Robert_F, thanks for trying.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.