Moved core from Synology 918+ NAS to Mac mini - no more local audio devices

Roon Core Machine

Was a Synology 918+ NAS 1.8 most recent build (943) - everything worked fine

Moved Core to Mac Mini (2018) - restored backup - 1.8 (943) (this Mac used to be my Roon client when core was on NAS)

Networking Gear & Setup Details

AirPort Extreme → ethernet cable → Netgear switch → ethernet cable → Synology NAS

That same Netgear switch → ethernet cable → Netgear switch-2 → ethernet cable → Mac mini (2018) core

Netgear switch 2-> ethernet cable → Mac studio (2022) Roon client

Connected Audio Devices

When running Roon client from Mac studio, I can only see connected audio devices on the core (Mac mini). I have a JDS Labs Element II DAC which does not show up on the Audio device list. Under “Audio This Mac” it lists 3 devices on the core Mac mini (System Output, Mac mini Speakers, and 28E850) - there is no local Mac Studio audio output devices even though the Roon client is running on the Mac Studio.

Library Size

5k albums, 44k tracks
Only local library (mounts to the NAS)

Problem

When running the Roon Client (player) on my Mac Studio connected to Roon Core on a Mac mini - the list of Audio Devices for “This Mac” are the list of Audio devices for the Mac mini (core) - not the Studio (player).

As outlined above, I am unable to see my local audio devices - only audio devices on the core. I do see room tested (networked) and other networked devices. So no problem there. I just can’t see the local system audio devices - I’m specifically looking from my DAC but the system output should be the local system output, not the core system output.

I ended up removing the RAATServer directory on local and core machines. I then turned off firewalls on both Macs. I turned off VPNs as well. I deleted the core and recreated an empty one from scratch - adding new music. But it never displays local audio devices when running roon from the core.

Note that when the Synology 918+ was the core, I could see my local Mac studio AND Mac mini audio devices. So if the DAC was connected to either, I could play to it.

I also tried running the roonbridge on the Mac studio but that didn’t show up either (I assume that would be networked). The only Mac studio “other network devices” I see is “via Airplay”)

Thanks for any suggestions on how I can use my DAC with Roon on my Mac studio with the core on a Mac mini.
Dan

Stupid question maybe but…is the DAC turned on?
Roon will only see a USB connected DAC when it’s on, and I assume it’s a USB connection.

Also have you rebooted the AirPort Extreme, then rebooted each Mac, then restarted Roon on the Core Mac and the Roon Client on the Mac Mini in that order?

Hahaha. Yes. The Audio on “This Mac” is definitely the audio on the Core - not the machine I’m running the player on that has the DAC connected. I can see the DAC on the Mac audio device list - so it’s definitely turned on (I see the light on it as well). I even unplugged/replugged/power cycled the DAC.

If for example I play “System Output” on “This Mac” - it goes to the core Mac mini. It also lists the “Mac mini” speakers under “This Mac”.

Shut everything down and restarted. Once Mac mini core was running, started Mac studio and ran Roon client (with DAC connected to studio). Still viewing audio devices connected to the Mac mini core

Did you do a fresh RoonServer install on the mac mini?

Thanks. Yes. I removed both Roon installs - client and core. I removed all Roon directories under Livrary. Then reinstalled core. Then reinstalled client. Add one small shared folder with some music. Exhibited same problem.

When the Roon Core was on the Synology (same networking) the Roon Client correctly displayed the local audio devices - so if the DAC was connected to the Mac mini, it could be used to play music. If the DAC was connected to the Mac studio, it could be used to play music. Only after I moved the core to the Mac mini did the Mac studio Roon Client not function as expected.

I’ve found this in the RAATServer log file on the Mac studio running the Roon client - so it’s definitely discovering the DAC - it’s just no displaying it as an audio device - in fact, none of these audio devices are displayed - only the devices on the Roon core Mac mini:

05/23 10:37:01 Trace: [raatmanager/mac] FOUND id=AppleUSBAudioEngine:CalDigit, Inc.:CalDigit Thunderbolt 3 Audio:6200000:1 usb_id=2188:6533
05/23 10:37:01 Trace: [raatmanager/mac]       vendor=CalDigit, Inc.                 name=CalDigit Thunderbolt 3 Audio   outname=Speaker 
05/23 10:37:01 Trace: [raatmanager/mac] FOUND id=AppleUSBAudioEngine:JDS Labs:JDS Labs Element II:9300000:1 usb_id=20b1:30da
05/23 10:37:01 Trace: [raatmanager/mac]       vendor=JDS Labs                       name=JDS Labs Element II            outname=        
05/23 10:37:01 Trace: [raatmanager/mac] FOUND id=AppleUSBAudioEngine:LG Electronics Inc.:LG UltraFine Display Audio:a241000:2 usb_id=043e:9a66
05/23 10:37:01 Trace: [raatmanager/mac]       vendor=LG Electronics Inc.            name=LG UltraFine Display Audio     outname=        
05/23 10:37:01 Trace: [raatmanager/mac] FOUND id=BuiltInSpeakerDevice usb_id=
05/23 10:37:01 Trace: [raatmanager/mac]       vendor=Apple Inc.                     name=Mac Studio Speakers            outname=Mac Studio Speakers
05/23 10:37:01 Trace: [raatmanager] initialized

And I tried connecting the client to wifi instead of ethernet… no difference. Any other suggestions on what to try?

The netgear switches are managed or unmanaged. Managed switches can interfere with discovery processes. Take a look at roon’s network FAQ: https://help.roonlabs.com/portal/en/kb/articles/networking-best-practices

Thanks. They’re unmanaged switches.

I used another iMac over WiFi and fresh install of Roon client. Everything worked as expected.

So since the Mac Studio did not work over wifi , it must be the install itself. I will try to completely remove every trace of Roon software and files - reboot … maybe reboot a few times for good luck … and reinstall. Crossing fingers.

2 Likes

No luck. Removed every trace from both Mac mini core and Mac studio client. Created a new core install on mini and added one share of music. But the audio devices listed on the client “My Computer” in settings are the audio devices on the core Mac mini.

I see my problem is similar to Roon confusing my computer’s audio devices with core’s audio devices

That was solved by re-installing windows - which I will not do (nor re-install Mac OS).

The Mac mini core has had Mac OS on it for a while (with os upgrades) AND had a Roon client that I have removed since installing Roon core. The Mac studio is a few weeks old and I used the Migration assistant to move apps over.

I just reconnected the Mac Studio to a core on the Synology and lo and behold - the audio devices under the “Mac Studio” are correct- I can see the DAC.

So @support - it appears even if I remove every last trace of Roon files on the Mac mini and Mac studio and re-install - it still is confusing audio devices between the Mac running the client with the ones on the core. So something is left that I didn’t remove - OR - you’re storing something in the “cloud” that is confused about which Mac (my core or client) is looking to play music.

Are you restoring from backup? And did you ever use Apple Migrate from the Mac Studio to the Mini or visa versa?

If you use a copy tool such as Migration Assistant, you will need to delete (or rename) the following files and directories in addition to the RoonServer directory before reinstalling RoonServer.

If you use a copy tool such as Migration Assistant, you will need to delete (or rename) the following files and directories in addition to the RoonServer directory before reinstalling RoonServer.

~/.rmembid
~/Library/RAATServer

Yes - $HOME/.rmembid was the thorn in my side! I had removed RAATServer before. But once I removed .rmembid on the Mac Studio and re-launched Roon - it displays audio devices correctly!!

Thank you all!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.