Moved SSD from external USB to internal SATA

Hi all!

I got a new fanless Akasa case for my Intel NUC. With this case I’m able to mount my former external USB connected SSD to the internal SATA ports and fix it inside the case.

After rebooting ROCK and calling the preferences page it tells me I have to initialize/format the internal disk space on SATA!

I don’t want to because then I’ll have to backup my complete 1TB audio data files and restore them after formatting the disk. Also I think the ROON database needs to be initialized and build new again.

Any chance to tell ROCK just to use the SSD without formatting? At least the SSD is already formatted and should work without any initialization.

I don’t think so. ROCK wants to initialize any new (to it) installed internal storage.

Like you said, you will probably need to backup all your music, reformat and then copy the music back across the the network. Or, you could just keep it as an external drive, which is what I’d suggest.

Also, remember, while you may have been able to use an external drive for both music and backups, you cannot do that with an internal drive in a ROCK system. So, you will still need an external drive as a backup location, or, set up backups to occur across the network to a share on another computer.

Ok, thanks. Then I’ll backup and format now…

Is it possible to start an internal copy with ROCK? I connected my backup with USB to the NUC, but the copy via MacOs network mounts of Rock/Data has only 5.4 MB/s (obviously over 10 MBit network connection). Which is a long, long time for 950GB of data…

Also I got permission denied errors after copying ca. 50GB on the target network mount Rock/Data/Internal/Storage. Two times now.

Unfortunately there is no way round copying via your network to the internal drive. Roon cant handle attaching a USB and copying across form that USB to the internal drive. Although that would certainly be a worthwhile feature to have - if not an absolut necessity.

The permission denied could be network related? Cant you temporarily set up a configuration where you connect both the USB drive and the ROCK to your router and establish a 1GB Network that way? If your router can only handle 10MBit, then its definityl time to get a new one :slightly_smiling_face:

Copying that amount via a 10MBit network is hell.

I’ll try. I have GB-switches/routers and CAT5 cable everywhere in my network, so it’s possibly a MacOS problem.

I’d be surprised, as I just copied my stuff to an internal drive via a Mac and GBit-Network. My cable is only 5e (done 12 years ago, was the best option then). It handles even a 5GBit connection between NAS and my office

NB: If you use a laptop (Macbook etc) make sure its on power and all energy saving options are disabled while you copy. Because if this thing goes to sleep after a few minutes, your network connection may be gone.

I found the problem: one of my switches seems to be defect, only performs with 10MBit/s. Thanks to all, now it works fast.


I didn’t find the solution yet. Now the connection is fast, but every 10-15GB of data transfer I get a “filename too long” error. For normal files/filenamelength. I didn’t see this error during copy of the file while using the same SSD as external USB drive. So this is a no-errer error…

To solve the problem I tried to connect the SSD (initialized by ROCK as internal drive) with the USB SSD adapter again direct to my MacBook - I get an error message the SSD cannot be read by the MacBook (and I should initialize the drive).

WTF! Which abstruse filesystem are you using with ROCK internal drives?!?

It’s frustrating, internal drives with ROCK seem to be a kind of magic. I’m the first using this?

EDIT: some .cue files have very long filenames. During copy the long filename is displayed scrambled/shortened in the errormessage.

Now I deleted all .cue files with find -delete. Next try. Weird stuff…

You should definitely not remove a Roon formated internal SSD and then attach it by adapter to a computer. that might corrupt the previously formatted disk.

I agree that the current process to get an internal Rock SSD loaded with music is way too messy. But it does work if you follow the guidelines. I loaded close to 3TB of music on my internal SSD just a week ago or so. The process is crap, but its possible.

Now that you had the SSD removed from Rock and attached to a PC, it may be currupt. Do you still see whar you copied so far when you reinsert the SSD and access via network? Otherwise you may have to reformat the SSD and start over. Leave it in the ROCK!!!

That filename error could well come from those cue files.

See where you get otherwise @support has to jump in.

Yes, I can still see the already copied files after reconnecting the drive as internal SSD to ROCK. Actual the copy process is running… Wait and see.

Fingers crossed

I’m software developer and Linux expert since 35 years now and fighted many strange problems during this time…

This leads me to the question: which filesystem is used by internal drives in ROCK? Just interesting for me.

EXT4 as far as I know. But Im no Software guy :rofl:

Oups, no EXT4 driver on my MacBook? Shame on me…

I think that it is ext4.