Moved to different Core and "Date Added" field is not displayed on tracks page

This seems like a simple issue for experienced users like me, but I cannot find the damn option to make it show up in the bar above ANY of my playlists. Everything else is there of course, Song Title, Length, Artist, Album Release Date, etc. but no Date Added!

I went into Settings > General, and there is a “Date-Added Sort Order” dropdown which would seem to indicate that it’s SUPPOSED to be displayed in my playlists, but no matter what setting I choose there “Date Added” is NOT displayed for any of them.

What the heck am I doing wrong/missing here? Can’t post a screen shot easily since my Core is a different PC (Intel NUC running Windows 10). Edited to add some pics from my camera.

Do I change the setting for “Album Dates for Sorting”?
If so duh…trying that now. NOPE - that just has release date sorting.
Can anyone help?

OK Issue solved. It’s the little blue downward arrow kind of tucked away at the corner of the Sort Bar. If you click it a group of option sliders open up to add or remove from the bar, and of course “Date Added” is one of them. Default must be not to show it on new installations. Duh…but geez I don’t always have time to spend clicking on every possible option and I guess I’m used to Windows/MS functionality where adding those things are in a different place.

I’ll untag support in my OP.